1. 程式人生 > >Spreading the Wealth,UVa 11300

Spreading the Wealth,UVa 11300

【題目】
A Communist regime is trying to redistribute wealth in a village. They have have decided to sit everyone around a circular table. First, everyone has converted all of their properties to coins of equal value, such that the total number of coins is divisible by the number of people in the village. Finally, each person gives a number of coins to the person on his right and a number coins to the person on his left, such that in the end, everyone has the same number of coins. Given the number of coins of each person, compute the minimum number of coins that must be transferred using this method so that everyone has the same number of coins.
【Input】
There is a number of inputs. Each input begins with n (n < 1000001), the number of people in the
village. n lines follow, giving the number of coins of each person in the village, in counterclockwise
order around the table. The total number of coins will fit inside an unsigned 64 bit integer.
【Output】
For each input, output the minimum number of coins that must be transferred on a single line.
【Sample Input】
3
100
100
100
4
1
2
5
4
【Sample Output】
0
4
【題解】
這是一道推導求中位數的題,看過書上的推導之後一直很迷,覺得遞推C陣列的式子不對,思考之後發現我沉迷在書上枯燥的推導式中,失去了題的原意,浪費了很長時間。

#include <cstdio>
#include <algorithm>

using namespace std;
const int maxn = 1000000 + 10;
long long A[maxn], C[maxn], tot, M;

int main() {
    int n;
    while (scanf("%d", &n) == 1) {
        tot = 0;
        for (int i = 1; i <= n; i++) {
            scanf("%lld", &A[i]);            //用%lld輸入long long
tot += A[i]; } M = tot / n; C[0] = 0; for (int i = 1; i < n; i++) C[i] = C[i - 1] + A[i-1] - M; //遞推C陣列 sort(C, C + n); long long x1 = C[n / 2], ans = 0; //計算x1 for (int i = 0; i < n; i++) ans += abs
(x1 - C[i]); //把x1代入,計算轉手的總金幣數 printf("%lld\n", ans); } return 0; }