Throwing cards away I (佇列)
個人分類: ACM題解ACM模擬ACM標準模板庫STLACM-UVAACM資料結構ACM Ad Hoc
所屬專欄: ACM題解
Given is an ordered deck of n cards numbered 1to n with card 1 at the top and card n at the bottom. The following operation is performed as long as there are at least two cards in the deck:
Throw away the top card and move
the card that is now on the top of the
deck to the bottom of the deck.
Your task is to find the sequence of discarded cards and the last, remaining card.
Input
Each line of input (except the last) contains a number n ≤ 50. The last line contains ‘0’ and this line should not be processed.
Output
For each number from the input produce two lines of output. The first line presents the sequence of discarded cards, the second line reports the last remaining card. No line will have leading or trailing spaces. See the sample for the expected format.
Sample Input
7
19
10
6
0
Sample Output
Discarded cards: 1, 3, 5, 7, 4, 2
Remaining card: 6
Discarded cards: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19, 4, 8, 12, 16, 2, 10, 18, 14
Remaining card: 6
Discarded cards: 1, 3, 5, 7, 9, 2, 6, 10, 8
Remaining card: 4
Discarded cards: 1, 3, 5, 2, 6
Remaining card: 4
本題的大意是,給定n張牌,標號從1到n,每次操作都先扔掉當前佇列中的第一張牌,然後再將隊頭的牌移到隊尾,輸出扔掉的牌的序列。可以使用類模板queue,程式碼如下:
#include<iostream>
#include<queue>
using namespace std;
int main()
{
int n;
while(cin>>n && n)
{
queue<int> a;
for(int i=1;i<=n;i++)
a.push(i);
bool fir=false;
cout << "Discarded cards:";
while(a.size()>1)
{
if(fir)
cout << ",";
fir=true;
cout << " " << a.front();
a.pop();//將第一張牌扔掉
a.push(a.front());//將隊頭的牌移到隊尾
a.pop();
}
cout << endl << "Remaining card: " << a.front() << endl;
}
return 0;
}