1. 程式人生 > >UVA10935 Throwing cards away I【模擬+queue+迴圈佇列】

UVA10935 Throwing cards away I【模擬+queue+迴圈佇列】

Given is an ordered deck of n cards numbered 1to n with card 1 at the top and card n at the bottom. The following operation is performed as long as there are at least two cards in the deck:

        Throw away the top card and move

        the card that is now on the top of the

        deck to the bottom of the deck.

  Your task is to find the sequence of discarded cards and the last, remaining card.


Input

Each line of input (except the last) contains a number n ≤ 50. The last line contains ‘0’ and this line should not be processed.

Output

For each number from the input produce two lines of output. The first line presents the sequence of discarded cards, the second line reports the last remaining card. No line will have leading or trailing spaces. See the sample for the expected format.

Sample Input

7

19

10

6

0

Sample Output

Discarded cards: 1, 3, 5, 7, 4, 2

Remaining card: 6

Discarded cards: 1, 3, 5, 7, 9, 11, 13, 15, 17, 19, 4, 8, 12, 16, 2, 10, 18, 14

Remaining card: 6

Discarded cards: 1, 3, 5, 7, 9, 2, 6, 10, 8

Remaining card: 4

Discarded cards: 1, 3, 5, 2, 6

Remaining card: 4

問題簡述:(略)

問題分析:(略)

程式說明

  這是一個模擬問題,直接使用佇列(queue)來模擬即可。

  然而,效率更高的做法是,自己構建一個迴圈佇列來實現模擬。需要注意的是,那個佇列的儲存單元至少要比最大值大1,否則會出現下標異常。

題記:(略)

參考連結:(略)

AC的C語言程式如下:
/* UVA10935 Throwing cards away I */

#include <stdio.h>

#define N (50 + 1)
int cq[N], headcq, tailcq;

void pushcq(int v)
{
    cq[tailcq++] = v;
    tailcq %= N;
}

void popcq()
{
    headcq++;
    headcq %= N;
}

int frontcq()
{
    return cq[headcq];
}

int sizecq()
{
    return (tailcq + N - headcq) % N;
}

void initcq()
{
    headcq = tailcq = 0;
}

int main(void)
{
    int n, i;

    while(~scanf("%d", &n) && n) {
        initcq();

        for(i=1; i<=n; i++)
            pushcq(i);

        printf("Discarded cards:");

        int nofirst = 0;
        while(sizecq() >= 2) {
            if(nofirst)
                printf(",");
            nofirst = 1;

            printf(" %d", frontcq());

            popcq();
            pushcq(frontcq());
            popcq();
        }
        printf("\nRemaining card: %d\n", frontcq());
    }

    return 0;
}


AC的C++語言程式如下:

/* UVA10935 Throwing cards away I */

#include <iostream>
#include <queue>

using namespace std;

int main()
{
    int n;

    while(cin >> n && n) {
        queue<int> q;

        for(int i=1; i<=n; i++)
            q.push(i);

        cout << "Discarded cards:";

        bool nofirst = false;
        while(q.size() >= 2) {
            if(nofirst)
                cout << ",";
            nofirst = true;

            cout << " " << q.front();

            q.pop();
            q.push(q.front());
            q.pop();
        }
        cout << endl << "Remaining card: " << q.front() << endl;
    }

    return 0;
}