1. 程式人生 > >hdu1163 Eddy's digital Roots(合九法+同餘定理)

hdu1163 Eddy's digital Roots(合九法+同餘定理)


Digital Roots
Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 84156    Accepted Submission(s): 26272


Problem Description
The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.
 

Input
The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.
 

Output
For each integer in the input, output its digital root on a separate line of the output.
 

Sample Input
24 39 0
 

Sample Output
6 3
 


思路: 

合九法這;個數字根等於原數除以9的餘數,因此這個計算過程常常稱為“合九法”。如39/9=3.成立

同餘定理:如果兩個乘積除以m的餘數等於這兩個數分別除以m的餘數積。 例如:7%3=1 5%3=2 7*5/3=2=1*2


程式碼:

//
//  main.cpp
//  hdu1163
//
//  Created by zhan_even on 2018/10/31.
//  Copyright © 2018年 zhan_even. All rights reserved.
//

#include <iostream>
using namespace std;
int main(int argc, const char * argv[]) {
    int n,sum;
    while (cin>>n&&n) {
        sum = 1;
        for (int i =0 ; i<n; i++) {
            sum = sum*n%9;
        }
        if (sum == 0) {
            cout<<"9"<<endl;
        }
        else
            cout<<sum<<endl;
    }
    return 0;
}