1. 程式人生 > >《資料結構》10-排序5 PAT Judge

《資料結構》10-排序5 PAT Judge

題目

The ranklist of PAT is generated from the status list, which shows the scores of the submissions. This time you are supposed to generate the ranklist for PAT.

Input Specification:
Each input file contains one test case. For each case, the first line contains 3 positive integers, N (≤10

4 ^4 ​​ ), the total number of users, K (≤5), the total number of problems, and M (≤10 5 ^5 ​​ ), the total number of submissions. It is then assumed that the user id’s are 5-digit numbers from 00001 to N, and the problem id’s are from 1 to K. The next line contains K positive integers p[i] (i=1, …, K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submission in the following format:

user_id problem_id partial_score_obtained
where partial_score_obtained is either −1 if the submission cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:
For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]
where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then “-” must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id’s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -

分析

題目大意:給出一組提交資料及相關資訊,排序後輸出結果
這道題細節比較多:

  1. 排序是先按總分,再按解題數,再其次 id 序號,所以可能排序後,那些不被顯示的,反而排在被顯示但是總分為0的前面(因為總分初始化都是0,而id號不被顯示的人更小一些),解決辦法是把id序號初始到很大,當確定此人被顯示,再把id序號"還"給他
  2. 不被顯示的只有兩種人:一道題也沒提交的和一道題也沒通過編譯的,所以即使是提交得分為 0,也會被顯示,解決方法是"還"id序號的時候計數器+1
  3. 某人某道題已經滿分但是提交了多次,算正確一道題,解決方法是把所有得分讀入完成後再確定正確題目數
#include<cstdio>
#include<algorithm>
#include<vector>

const int INIT = -2;  // 初始化 
const int NOPASS = -1;  // 未通過編譯 
const int MAXID = 10005;  //最大ID 
using namespace std;

struct info{
	int id;    // id號 
	int ques[6];  // 每道題得分
	int sum;   // 總分 
	int solved;   // 答對題數 
};

// 定義sort 的排序規則 
bool cmp(info a,info b){
	if(a.sum != b.sum)
		return a.sum>b.sum;	
	if(a.solved != b.solved)
		return a.solved > b.solved;
	return a.id < b.id;
}


int main(){
	int N;  // 使用者總數
	int K;  // 問題總數
	int M;  // 提交總數 
	scanf("%d %d %d",&N,&K,&M);
	vector<info> user(N+1); // 使用者資訊
	int Full[K+1];  // 記錄問題總分 ,a[i] 表示第i道題的分數
	for(int i=1;i<=K;i++) 
		scanf("%d",&Full[i]);
	// 初始化資訊 
	for(int i=1;i<N+1;i++){
		user[i].id = MAXID;  // 初始化成最大 
		user[i].sum = 0; 
		user[i].solved = 0;
		for(int j=1;j<K+1;j++) 
			user[i].ques[j] = INIT;
	}
	int use;  // 玩家編號 
	int question;  // 問題編號 
	int score;  // 得分 
	int listSum = 0; // 應該被輸出總數 
	for(int i=0;i<M;i++){
		scanf("%d %d %d",&use,&question,&score);
		// 只要通過編譯,該玩家就能被顯示
		if(score >= 0 && user[use].id == MAXID){
			listSum++;
			user[use].id = use;
		} 
		// 分數有更大更新成更大 
		if(user[use].ques[question] < score){
			user[use].ques[question] = score;
		}
	}
	for(int i=1;i<N+1;i++)
		for(int j=1;j<K+1;j++){
			// 計算完全正確解題數 
			if(user[i].ques[j] == Full[j])
				user[i].solved++;
			// 計算總分 
			if(user[i].ques[j] != NOPASS && user[i].ques[j] != INIT)
				user[i].sum += user[i].ques[j];
		} 
	
	sort(user.begin()+1,user.end(),cmp);
	
	int preSum = user[1].sum;
	int preNum = 1;
	
	for(int i=1;i<=listSum;i++){ 
	    // 如果和上次分數不同,更新排名 
		if(preSum != user[i].sum){ 
			preNum = i;
			preSum = user[i].sum;
		} 
		printf("%d ",preNum);
		printf("%05d %d",user[i].id,user[i].sum);
		for(int j=1;j<K+1;j++){
			// 依舊初始化狀態 
			if(user[i].ques[j] == INIT)
				printf(" -");
			else if(user[i].ques[j] == NOPASS)
				printf(" 0");
			else
				printf(" %d",user[i].ques[j]);
		}
		printf("\n");
	}
	return 0;
}