PAT 1035 Password (20 分)String的性質 燚
To prepare for PAT, the judge sometimes has to generate random passwords for the users. The problem is that there are always some confusing passwords since it is hard to distinguish 1
(one) from l
(L
in lowercase), or 0
(zero) from O
(o
in uppercase). One solution is to replace 1
@
, 0
(zero) by %
, l
by L
, and O
by o
. Now it is your job to write a program to check the accounts generated by the judge, and to help the juge modify the confusing passwords.
Input Specification:
Each input file contains one test case. Each case contains a positive integer N (≤1000), followed by N lines of accounts. Each account consists of a user name and a password, both are strings of no more than 10 characters with no space.
Output Specification:
For each test case, first print the number M of accounts that have been modified, then print in the following M lines the modified accounts info, that is, the user names and the corresponding modified passwords. The accounts must be printed in the same order as they are read in. If no account is modified, print in one line There are N accounts and no account is modified
N
is the total number of accounts. However, if N
is one, you must print There is 1 account and no account is modified
instead.
Sample Input 1:
3
Team000002 Rlsp0dfa
Team000003 perfectpwd
Team000001 R1spOdfa
Sample Output 1:
2
Team000002 RLsp%dfa
Team000001 [email protected]
Sample Input 2:
1
team110 abcdefg332
Sample Output 2:
There is 1 account and no account is modified
Sample Input 3:
2
team110 abcdefg222
team220 abcdefg333
Sample Output 3:
There are 2 accounts and no account is modified
題意: 由於某些數字與一些英文字母很相似可能造成一些混亂,現將密碼字串中的 數字 1 替換為@ 數字0 替換為% 小寫字母l 替換為L 大寫字母O 替換為小寫o
輸入:第一行:輸入正整數N 表示要輸入的資訊個數
剩下N行:賬號 密碼
輸出:如果有被修改的字串,則輸出被修改資訊的個數以及修改過後的內容
如果所有密碼字串都沒有被修改,若輸入數量>1則輸出:There are N accounts and no account is modified
否則輸出:There is 1 account and no account is modified
思路:逐個檢測字串的每一位,用switch 語句判斷並改整需要修改的字元。
知識點:string型別在記憶體中為連續儲存,類似與字元陣列,但string 為連續容器它與vector容器很相似,並且可以共用很多操作函式。
#include<iostream>
#include<vector>
#include<string>
using namespace std;
struct Count {
string name;
string psw;
};
void input(vector<Count> &count) {
int n;
cin >> n;
count.resize(n);
for (int i = 0;i < n;i++) {
cin >> count[i].name >> count[i].psw;
}
}
void changeThePsw(vector<Count> &count, vector<int> &index) {
for (int i = 0;i < count.size();i++) {
bool flag = false; //判斷密碼中是否有可修改的字元,若有flag=true
int j = 0;
//檢測密碼字串的每一位,並判斷是否修改
for (;j < count[i].psw.size();j++) {
switch (count[i].psw[j]) {
case 'l':count[i].psw[j] = 'L';flag = true;break;
case 'O':count[i].psw[j] = 'o';flag = true;break;
case '0':count[i].psw[j] = '%';flag = true;break;
case '1':count[i].psw[j] = '@';flag = true;break;
}
}
if(flag)
index.push_back(i);//將修改過後的結構體 下標 存入容器中
}
}
int main() {
vector<Count> count;
vector<int>index;
input(count);
changeThePsw(count, index);
if (index.empty() && count.size() > 1) {
cout << "There are " << count.size() << " accounts and no account is modified" << endl;
}
else if (index.empty() && count.size() == 1) {
cout << "There is 1 account and no account is modified" << endl;
}
else {
cout << index.size() << endl;
for (auto i = index.begin();i != index.end();i++) {
cout << count[(*i)].name << " " << count[(*i)].psw << endl;
}
}
}