1. 程式人生 > >PAT 1077 Kuchiguse (20 分)

PAT 1077 Kuchiguse (20 分)

1077 Kuchiguse (20 分)

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker’s personality. Such a preference is called “Kuchiguse” and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle “nyan~” is often used as a stereotype for characters with a cat-like personality: Itai nyan~ (It hurts, nyan~) Ninjin wa iyada nyan~ (I hate carrots, nyan~)

Now given a few lines spoken by the same character, can you find her Kuchiguse?

Input Specification: Each input file contains one test case. For each case, the first line is an integer N (2≤N≤100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character’s spoken line. The spoken lines are case sensitive.

Output Specification: For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write nai.

Sample Input 1:

3
Itai nyan~
Ninjin wa iyadanyan~
uhhh nyan~

Sample Output 1:

nyan~

Sample Input 2:

3
Itai!
Ninjinnwaiyada T_T
T_T

Sample Output 2:

nai

解析

題意是尋找一組字串中最大相同字尾,並輸出。如果沒有:則輸出‘nai’ 最大相同字尾:完全可以使用reverse_iterator反向迭代器。這樣思路就類似尋找最大相同字首。 Code:

#include<string>
#include<vector>
#include<iostream>
#include<utility>
using namespace std;
const string out = "nai";
int main()
{
	int N;
	cin >> N;
	getchar();
	vector<string> spoken(N);
	vector<string::reverse_iterator> it(N);
	string result;
	for (int i = 0; i < N; i++) {
		getline(cin,spoken[i]);
		it[i] = spoken[i].rbegin();
	}
	bool Continue = true;
	while (Continue) {
		auto first = it[0];
		for (int i = 0; i < N && Continue; i++) {
			if (it[i] == spoken[i].rend() || *first != *it[i]) {  //到尾巴了  或 不是最大字尾
				Continue = false;
				break;
			}
			it[i]++;
		}
		if(Continue)
			result = *first + result;
	}
	if (result.empty())
		cout << out;
	else
		cout << result;
}