[期望] A - A Dangerous Maze LightOJ - 1027
You are in a maze; seeing n doors in front of you in beginning. You can choose any door you like. The probability for choosing a door is equal for all doors.
If you choose the ith door, it can either take you back to the same position where you begun in ximinutes, or can take you out of the maze after xi
Now you want to find the expected time to get out of the maze.
Input
Input starts with an integer T (≤ 100), denoting the number of test cases.
Each case contains a blank line and an integer n (1 ≤ n ≤ 100) denoting the number of doors. The next line contains n space separated integers. If the ith integer (xi) is positive, you can assume that the ith door will take you out of maze after xi
Output
For each case, print the case number and the expected time to get out of the maze. If it's impossible to get out of the maze, print 'inf'. Print the result in p/q format. Where p is the numerator of the result and q is the denominator of the result and they are relatively prime. See the samples for details.
Sample Input
3
1
1
2
-10 -3
3
3 -6 -9
Sample Output
Case 1: 1/1
Case 2: inf
Case 3: 18/1
設期望為x 以第三組樣例為例
x = 1 / 3 * 3 + 1 / 3 * (6 + x) + 1 / 3 * (9 + x);
#include <bits/stdc++.h>
using namespace std;
int main()
{
int T;
scanf("%d", &T);
for (int cas = 1; cas <= T; cas++)
{
int n;
scanf("%d", &n);
int p = 0, sum = 0;
for (int i = 1; i <= n; i++)
{
int a;
scanf("%d", &a);
if (a > 0)
{
p++;
sum += a;
}
else
sum += -a;
}
if (p == 0)
printf("Case %d: inf\n", cas);
else
{
int t = __gcd(sum, p);
printf("Case %d: %d/%d\n", cas, sum / t, p / t);
}
}
return 0;
}