1. 程式人生 > >HDU 2061 - Treasure the new start, freshmen!

HDU 2061 - Treasure the new start, freshmen!

Treasure the new start, freshmen!

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 22232    Accepted Submission(s): 6584


 

Problem Description

background:
A new semester comes , and the HDU also meets its 50th birthday. No matter what's your major, the only thing I want to tell you is:"Treasure the college life and seize the time." Most people thought that the college life should be colorful, less presure.But in actual, the college life is also busy and rough. If you want to master the knowledge learned from the book, a great deal of leisure time should be spend on individual study and practise, especially on the latter one. I think the every one of you should take the learning attitude just as you have in senior school.
"No pain, No Gain", HDU also has scholarship, who can win it? That's mainly rely on the GPA(grade-point average) of the student had got. Now, I gonna tell you the rule, and your task is to program to caculate the GPA.
If there are K(K > 0) courses, the i-th course has the credit Ci, your score Si, then the result GPA is
GPA = (C1 * S1 + C2 * S2 +……+Ci * Si……) / (C1 + C2 + ……+ Ci……) (1 <= i <= K, Ci != 0)
If there is a 0 <= Si < 60, The GPA is always not existed.

 

Input

The first number N indicate that there are N test cases(N <= 50). In each case, there is a number K (the total courses number), then K lines followed, each line would obey the format: Course-Name (Length <= 30) , Credits(<= 10), Score(<= 100).
Notice: There is no blank in the Course Name. All the Inputs are legal

 

Output

Output the GPA of each case as discribed above, if the GPA is not existed, ouput:"Sorry!", else just output the GPA value which is rounded to the 2 digits after the decimal point. There is a blank line between two test cases.

 

Sample Input

2

3

Algorithm 3 97

DataStruct 3 90

softwareProject 4 85

2

Database 4 59

English 4 81

 

Sample Output

90.10

Sorry!

題意:

     計算學生的學分,如果有一科成績不滿60分就不進行計算。

     陣列不要開小了,之前陣列開小了WA了好幾次,竟然不是RE!

程式碼:

#include<stdio.h>
int main()
{
	int t,n,i,flag;
	double sum,s;
	char str[50];
	double a[1010],b[1010];
	scanf("%d",&t);
	while(t--)
	{
		flag=sum=s=0;
		scanf("%d",&n);
		for(i=1;i<=n;i++)
		{
			scanf("%s%lf%lf",str,&a[i],&b[i]);
		}
		for(i=1;i<=n;i++)
		{
			if(b[i]<60&&b[i]>=0)
			{
				flag=1;
				break;
			}
		}
		if(!flag)
		{
			for(i=1;i<=n;i++)
			{
				sum+=a[i]*b[i];
			}
			for(i=1;i<=n;i++)
				s+=a[i];
			sum/=s;
		}
		if(flag)
			printf("Sorry!\n");
		else
			printf("%.2f\n",sum);
		if(t!=0)
			printf("\n");
	}
	return 0;
}