1. 程式人生 > >hdu 2061 Treasure the new start, freshmen!

hdu 2061 Treasure the new start, freshmen!

Treasure the new start, freshmen!

Problem Description

background:
A new semester comes , and the HDU also meets its 50th birthday. No matter what's your major, the only thing I want to tell you is:"Treasure the college life and seize the time." Most people thought that the college life should be colorful, less presure.But in actual, the college life is also busy and rough. If you want to master the knowledge learned from the book, a great deal of leisure time should be spend on individual study and practise, especially on the latter one. I think the every one of you should take the learning attitude just as you have in senior school.
"No pain, No Gain", HDU also has scholarship, who can win it? That's mainly rely on the GPA(grade-point average) of the student had got. Now, I gonna tell you the rule, and your task is to program to caculate the GPA.
If there are K(K > 0) courses, the i-th course has the credit Ci, your score Si, then the result GPA is
GPA = (C1 * S1 + C2 * S2 +……+Ci * Si……) / (C1 + C2 + ……+ Ci……) (1 <= i <= K, Ci != 0)
If there is a 0 <= Si < 60, The GPA is always not existed.

Input

The first number N indicate that there are N test cases(N <= 50). In each case, there is a number K (the total courses number), then K lines followed, each line would obey the format: Course-Name (Length <= 30) , Credits(<= 10), Score(<= 100).
Notice: There is no blank in the Course Name. All the Inputs are legal

Output

Output the GPA of each case as discribed above, if the GPA is not existed, ouput:"Sorry!", else just output the GPA value which is rounded to the 2 digits after the decimal point. There is a blank line between two test cases.

Sample Input

2

3

Algorithm 3 97

DataStruct 3 90

softwareProject 4 85

2

Database 4 59

English 4 81

Sample Output

90.10

Sorry!

問題分析:

  • 注意輸出格式:There is a blank line between two test cases.(兩個測試用例之間有一條空行。)
  • 輸出的資料要四捨五入

原始碼

import java.util.Scanner;

public class Hello {
	public static void main(String[] args) {
		Scanner sc=new Scanner(System.in);
		int t=sc.nextInt();            //輸入有幾個測試
		while(t>0) {
			t--;
			int k=sc.nextInt();        /輸入幾門課程
			double sum=0,m=0;
			boolean tag=true;
			for(int i=0;i<k;i++) {
				String course=sc.next();           //課程
				double c=sc.nextDouble();          //學分
				double score=sc.nextDouble();      //成績
				sum=sum+c*score;                   //sum=學分*成績,累加
				m=m+c;                             //學分的總和
				if(score<60&&score>=0) 
					tag=false;                    //如果成績小於60,則為不合格
			}
			if(tag==true) 
				System.out.println(String.format("%.2f", (1.0*sum)/m));     //四捨五入
			else
				System.out.println("Sorry!");
			if(t>0)
				System.out.println();               //兩個測試用例之間有一條空行
		}
}
}