1. 程式人生 > >uva1593—— Alignment of Code 【stl,模擬】

uva1593—— Alignment of Code 【stl,模擬】

You are working in a team that writes Incredibly Customizable Programming Codewriter (ICPC) which is basically a text editor with bells and whistles. You are working on a module that takes a piece of code containing some definitions or other tabular information and aligns each column on a fixed vertical position, while keeping the resulting code as short as possible, making sure that only whitespaces that are absolutely required stay in the code. So, that the first words on each line are printed at position p1 = 1; the second words on each line are printed at the minimal possible position p2, such that all first words end at or before position p2 − 2; the third words on each line are printed at the minimal possible position p3, such that all second words end at or before position p3 − 2, etc. For the purpose of this problem, the code consists of multiple lines. Each line consists of one or more words separated by spaces. Each word can contain uppercase and lowercase Latin letters, all ASCII punctuation marks, separators, and other non-whitespace ASCII characters (ASCII codes 33 to 126 inclusive). Whitespace consists of space characters (ASCII code 32).

Input

The input file contains one or more lines of the code up to the end of file. All lines (including the last one) are terminated by a standard end-of-line sequence in the file. Each line contains at least one word, each word is 1 to 80 characters long (inclusive). Words are separated by one or more spaces. Lines of the code can have both leading and trailing spaces. Each line in the input file is at most 180 characters long. There are at most 1000 lines in the input file.

Output

Write to the output file the reformatted, aligned code that consists of the same number of lines, with the same words in the same order, without trailing and leading spaces, separated by one or more spaces such that i-th word on each line starts at the same position pi . Note for the Sample: The ‘⊔’ character in the example below denotes a space character in the actual files (ASCII code 32).

Sample Input 

␣␣start:␣␣integer;␣␣␣␣//␣begins␣here

stop:␣integer;␣//␣␣ends␣here

␣s:␣␣string;

c:␣␣␣char;␣//␣temp 

Sample Output

start:␣integer;␣//␣begins␣here

stop:␣␣integer;␣//␣ends␣␣␣here

s:␣␣␣␣␣string;

c:␣␣␣␣␣char;␣␣␣␣//␣temp

題目大意:給你一些字元,讓你把這組字元按樣例所給形式對其輸出。

大致思路:我們可以用vector儲存一個單詞矩陣,然後找單詞矩陣每一列的最大長度,格式化輸出就行了。

首先就是這道題的輸入問題,我們可以getline把字元按行輸入,在用stringstream最字元進行格式化存入vector中。最後輸出的時候我們要呼叫#include <iomanip> 中的setw函式進行格式化輸出。

至於setw,和stringstream的應用可以參考一下兩片部落格。

stringstream的使用

setw的使用 

接下來就是程式碼了:

#include <iomanip>
#include <bits/stdc++.h>
using namespace std;
vector<string> word[100010];
int maxlen[100010];
int main(){
    string s,t;
    int k = 0;
    memset(maxlen,0,sizeof(maxlen));
    while(getline(cin,s)){
        //按行讀入每一個字元
        stringstream ss(s); //把每一個字元轉化為標準形式
        //string t;
       // int k = 0;
        int i = 0;
        while(ss >> t){
           // cout<<t<<endl;
            maxlen[i] = max((int)t.length(),maxlen[i]);
            word[k].push_back(t);
           // cout<<t<<endl;
            //printf("%d\n",k);
            i++;
        }
        k++;
    }
  //  printf("%d\n",k);
    cout << setiosflags(ios::left);
    for(int i = 0; i < k; i++){
        int j;
        for(j = 0; j < (int)word[i].size()-1; j++){
            cout<<setw(maxlen[j] + 1)<<word[i][j];
        }
        cout << word[i][j] <<endl;
    }
    return 0;
}