1. 程式人生 > >Fence Repair POJ - 3253 (優先佇列)

Fence Repair POJ - 3253 (優先佇列)

優先佇列 

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li≤ 50,000) units. He then purchases a single long board just long enough to saw into the N

 planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the "kerf", the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn't own a saw with which to cut the wood, so he mosies over to Farmer Don's Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn't lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N

 planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks 
Lines 2.. N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8. 
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

  • 題意:有一個農夫要把一個木板鉅成幾塊給定長度的小木板,

  • 每一次費用就是當前鋸的這個木板的長度  給定小木板的個數n,

  • 各個要求的小木板的長度,,求最小費用

    題中給出的資料 8 5 8,按小為優先進入佇列即為5 8 8,

  • 要費用最小,即每次鋸成的兩塊木板的長度最小(這樣他們的和就最小),

  • 如題中資料,先選出5 和 8,      5+8=13,ans=ans+13,  13是倒數第一步鋸木頭的行為的木板長度, 

  • 接著 13 8進入佇列後自動以小優先排序即為 8 13,   在倒數第二步的鋸木頭行為

  • (在題中資料就是第一步了,因為就鋸兩次嗎) , 8+13=21,     ans=ans+21,   

  • 這樣最終ans 最小取得 34

  • #include <iostream>
    #include<string.h>
    #include<stdio.h>
    #include<queue>
    using namespace std;
    int main()
    {
        priority_queue<int,vector<int>,greater<int> >q;
        int n;
        scanf("%d",&n);
        for(int i=0; i<n; i++)
        {
            int x;
            scanf("%d",&x);
            q.push(x);
        }
      long long  ans=0;
        while(q.size()>1)
        {
            int a=q.top();
            q.pop();
            int b=q.top();
            q.pop();
            int c=a+b;
            q.push(c);
            ans+=c;
        }
        printf("%lld\n",ans);
        return 0;
    }