1. 程式人生 > >1282 Leading and Trailing 前3位

1282 Leading and Trailing 前3位

You are given two integers: n and k, your task is to find the most significant three digits, and least significant three digits of nk.

Input

Input starts with an integer T (≤ 1000), denoting the number of test cases.

Each case starts with a line containing two integers: n (2 ≤ n < 231) and k (1 ≤ k ≤ 107)

.

Output

For each case, print the case number and the three leading digits (most significant) and three trailing digits (least significant). You can assume that the input is given such that nk contains at least six digits.

Sample Input

5

123456 1

123456 2

2 31

2 32

29 8751919

Sample Output

Case 1: 123 456

Case 2: 152 936

Case 3: 214 648

Case 4: 429 296

Case 5: 665 669

題解:後3為直接%1000 取求就可以了

前3位 n^k=10^(k*lg(n))  k*lg(n) 正數部分a,小數部分b,10^a * 10^b  a為結果的位數 10^b 為小於10對應的數,科學計數法

取小數的時候 學到了一個新的方法fmod(n,1) 

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
int n,k;
int ksm(int a,int b)
{
	int ans=1;
	a%=1000;
	while(b)
	{
		if(b&1) ans=ans*a%1000;
		b>>=1;
		a=a*a%1000;
	}
	return ans;
}
int main()
{
	int T,nn=1;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d",&n,&k);
		int x=(int)(pow(10.0,2.0+fmod(k*log10(1.0*n),1)));
                //double p=k*log10(1.0*n); 
		//int x=(int)(pow(10.0,2.0+p-(int)p));
		int y=ksm(n,k);
		printf("Case %d: %d %03d\n",nn++,x,y);
	} 
	return 0;
}