1. 程式人生 > >直角座標系(Java)

直角座標系(Java)

Problem Description

X是一個喜歡數學的小孩,現在他剛剛學了座標系。他想知道點(X,Y)在第幾象限內。輸入資料保證點不在座標軸及原點上。

Input

 多組輸入。

每組輸入兩個整數X,Y,代表點(X,Y),中間用空格隔開。

Output

 輸出一個整數代表點在第幾象限內。

Sample Input

2 3
-2 -3

Sample Output

1
3

Java版:

import java.util.Scanner;
public class Main {
 
	public static void main(String[] args) {
     Scanner in = new Scanner(System.in);
     int a,b;
     while(in.hasNext()) {
    	 a = in.nextInt();
    	 b = in.nextInt();
    	 if(a>0&&b>0) {
    		 System.out.println("1");
    	 }
    	 else if(a>0&&b<0)
    		 System.out.println("4");
    	 else if(a<0&&b>0)
    		 System.out.println("2");
    	 else if(a<0&&b<0)
    		 System.out.println("3");

     }
    }
}