1. 程式人生 > >【POJ3252】Round Numbers

【POJ3252】Round Numbers

                                            Round Numbers

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 16392 Accepted: 6755

Description

The cows, as you know, have no fingers or thumbs and thus are unable to play Scissors, Paper, Stone' (also known as 'Rock, Paper, Scissors', 'Ro, Sham, Bo', and a host of other names) in order to make arbitrary decisions such as who gets to be milked first. They can't even flip a coin because it's so hard to toss using hooves.

They have thus resorted to "round number" matching. The first cow picks an integer less than two billion. The second cow does the same. If the numbers are both "round numbers", the first cow wins, otherwise the second cow wins.

A positive integer N is said to be a "round number" if the binary representation of N

has as many or more zeroes than it has ones. For example, the integer 9, when written in binary form, is 1001. 1001 has two zeroes and two ones; thus, 9 is a round number. The integer 26 is 11010 in binary; since it has two zeroes and three ones, it is not a round number.

Obviously, it takes cows a while to convert numbers to binary, so the winner takes a while to determine. Bessie wants to cheat and thinks she can do that if she knows how many "round numbers" are in a given range.

Help her by writing a program that tells how many round numbers appear in the inclusive range given by the input (1 ≤ Start < Finish ≤ 2,000,000,000).

Input

Line 1: Two space-separated integers, respectively Start and Finish.

Output

Line 1: A single integer that is the count of round numbers in the inclusive range Start..Finish

Sample Input

2 12

Sample Output

6

解析:

       數位DP。

       唯一的變化就是變成了二進位制,直接轉成二進位制後就是裸的數位DP了。

程式碼:  

#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstdlib>
#include <cstring> 
using namespace std;

const int Max=35;
int n,m,l,r;
int num[Max],f[Max][Max][2];

inline int dfs(int pos,int sum,int tag,int limit)
{
	if(!pos) return sum>=0?1:0;
	if(sum+pos<0) return 0;
	if(!limit&&~f[pos][sum][tag]) return f[pos][sum][tag];
	int mx=limit?num[pos]:1,ans=0,now=tag,add=0;
	for(int i=0;i<=mx;i++)
	{
	  if(i) now=1;
	  if(i==0&&now) add=1;
	  else if(i==1) add=-1;
	  ans+=dfs(pos-1,sum+add,now,limit&(i==mx));
	}
	if(!limit) return f[pos][sum][tag]=ans;
	return ans;
}

inline int solve(int x)
{
	n=0;
	while(x)num[++n]=x%2,x/=2;
	return dfs(n,0,0,1);
}

int main()
{
	memset(f,-1,sizeof(f));
	cin>>l>>r;
	cout<<solve(r)-solve(l-1);
	return 0;
}