1. 程式人生 > >DNA Sorting

DNA Sorting

Description

One measure of unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequenceDAABEC’’, this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence

ZWQM’’ has 6 inversions (it is as unsorted as can be—exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of sortedness'', from

most sorted’’ to least sorted''. All the strings are of the same length. Input The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n. **Output** Output the list of input strings, arranged from
most sorted’’ to ``least sorted’’. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input 10 6 AACATGAAGG TTTTGGCCAA TTTGGCCAAA GATCAGATTT CCCGGGGGGA ATCGATGCAT Sample Output CCCGGGGGGA AACATGAAGG GATCAGATTT ATCGATGCAT TTTTGGCCAA TTTGGCCAAA C語言版本

#include <stdio.h>
#include <stdlib.h>
#include <string.h>
/* run this program using the console pauser or add your own getch, system("pause") or input loop */

int main()
{
    int n, m;
    scanf("%d%d",&n,&m);
    int i,j,k;
    char str[50][101];
    int count[50];
   // int num[50];
    for(i=0;i<m;i++){
        count[i]=0;
        //num[i]=i+1;
    }
    for(i=0;i<m;i++){
        scanf("%s",str[i]);
    }
    for(i=0;i<m;i++){
        for(j=0;j<n;j++){
            for(k=j+1;k<n;k++){
                if(str[i][j]>str[i][k])
                    count[i]++;

    }


    }


    }
    char temp[101];
    int tmp;
    for(i=0;i<m;i++){
            
        for(j=m-1;j>i;j--){
            if(count[j-1]>count[j])

        
            tmp=count[j];
            count[j]=count[j-1];
            count[j-1]=tmp;

            strcpy(temp,str[j]);
            strcpy(str[j],str[j-1]);
            strcpy(str[j-1],temp);

       }

    }
    for(i=0;i<m;i++){
    	
        printf("%s\n",str[i]);
    }
  
    return 0;
}

C++版本

#include <stdio.h>
#include <iostream>
#include <string.h>
using namespace std;
 
 
 
int main()
{
	/* recept the parameters */
	int length = 0;
	int n = 0;
	cin>>length;
	cin>>n;
 
	char **DNASeq = new char* [n];
	for(int i=0; i<n; ++i)
	{	
		DNASeq[i] = new char[length];
		cin>>DNASeq[i];		
	}
	
 
	/* calculate the number of inversions */
	int *inversions = new int [n];
	for(int i=0; i<n; ++i)
	{	
		inversions[i] = 0; /* initiate the array of inversion number */
 
		for(int j=0; j<length; ++j)
			for(int k=j+1; k<length; ++k)
				if( DNASeq[i][j]>DNASeq[i][k])
					inversions[i]++;
				
	}
 
	/*Bubble sort*/
	for(int i=0; i<n; ++i)
		for(int j=n-1; j>i; --j)
			if( inversions[j] < inversions[j-1])
			{
				int temp        = inversions[j];    /*swap*/
				inversions[j]   = inversions[j-1];
				inversions[j-1] = temp;
 
				char *tmp   = DNASeq[j];
				DNASeq[j]   = DNASeq[j-1];
				DNASeq[j-1] = tmp;
			}
	
 
	/*OUTPUT*/
	for(int i=0; i<n; ++i)
	{	cout<<DNASeq[i]<<endl;	}
	
 
	return 0;
}