1. 程式人生 > >POJ1007 DNA Sorting【排序+逆序數】

POJ1007 DNA Sorting【排序+逆序數】

DNA Sorting
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 110791 Accepted: 44366

Description

One measure of unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequenceDAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence

ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of sortedness'', from

most sorted'' to ``least sorted''. All the strings are of the same length.

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from most sorted'' toleast sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

Source

East Central North America 1998

問題連結POJ1007 DNA Sorting
問題簡述:(略)
問題分析
    這個一個排序問題,需要先算一下每個字串的逆序數,根據逆序數進行排序。算逆序數採用暴力法進行計算。
程式說明:(略)
參考連結:(略)
題記:(略)

AC的C語言程式如下:

/* POJ1007 DNA Sorting */

#include <iostream>
#include <algorithm>
#include <stdio.h>

using namespace std;

const int N = 50;
const int M = 100;
struct Node {
    char s[N + 1];
    int inv;
} d[M];

bool cmp(Node a, Node b)
{
    return a.inv < b.inv;
}

int main()
{
    int n, m, i, j, k;
    while(~scanf("%d%d", &n, &m)) {
        for(i = 0; i < m; i++) {
            scanf("%s", d[i].s);
            d[i].inv = 0;       /* 計算逆序數 */
            for(j = 0; j < n; j++)
                for(k = j + 1; k < n; k++)
                    if(d[i].s[j] > d[i].s[k])
                        d[i].inv++;
        }

        sort(d, d + m, cmp);

        for(i = 0; i < m; i++)
            printf("%s\n", d[i].s);
    }

    return 0;
}