1. 程式人生 > >PAT-A 1152 Google Recruitment

PAT-A 1152 Google Recruitment

      In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google's hiring process by visiting this website.

      The natural constant e is a well known transcendental number(超越數). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921... where the 10 digits in bold are the answer to Google's question.

       Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

Input Specification:

Each input file contains one test case. Each case first gives in a line two positive integers: L (≤1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

Output Specification:

For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

Sample Input 1:

20 5

23654987725541023819

Sample Output 1:

49877

Sample Input 2:

10 3
2468024680

Sample Output 2:

404

題意:

       給出一串數字,指定位數k,求第一個出現的連續k位數字構成的素數,由於k小於10,不會超出int的範圍,所以只需要使用int儲存k位數,並判斷是否為素數。需要注意的是,題目中說明了,首位數字不可在前面補零,但其餘數字位上的零不可忽略,並要求原樣輸出,比如200236,k=4,則第一個4位素數是0023,不能輸出23。

Code:

#include <stdio.h>
#include <math.h>
using namespace std;

int n, k;

bool isPrime(int test){
    if(test == 0 || test == 1) return false;
    for(int i = 2; i * i <= test; i++){
        if(test % i == 0) return false;
    }
    return true;
}

int main(){
    scanf("%d %d", &n, &k);
    char num[1005];
    getchar();
    for(int i = 0; i < n; i++)
        scanf("%c", &num[i]);

    bool flag = false;
    for(int i = 0; i <= n - k; i++){
        int t = 0, c = 10;
        for(int j = i; j < i + k; j++)
            t = (t * c + (num[j] - '0'));
        flag = isPrime(t);
        if(flag){
            for(int j = i; j < i+ k; j++)
                printf("%c", num[j]);
            printf("\n");
            break;
        }
    }
    if(!flag) printf("404\n");
    return 0;
}