1. 程式人生 > >PAT-A 1155 Heap Paths

PAT-A 1155 Heap Paths

In computer science, a heap is a specialized tree-based data structure that satisfies the heap property: if P is a parent node of C, then the key (the value) of P is either greater than or equal to (in a max heap) or less than or equal to (in a min heap) the key of C. A common implementation of a heap is the binary heap, in which the tree is a complete binary tree. (Quoted from Wikipedia at

https://en.wikipedia.org/wiki/Heap_(data_structure))

One thing for sure is that all the keys along any path from the root to a leaf in a max/min heap must be in non-increasing/non-decreasing order.

Your job is to check every path in a given complete binary tree, in order to tell if it is a heap or not.

Input Specification

Each input file contains one test case. For each case, the first line gives a positive integer N (1<N≤1,000), the number of keys in the tree. Then the next line contains N distinct integer keys (all in the range of int), which gives the level order traversal sequence of a complete binary tree.

Output Specification

For each given tree, first print all the paths from the root to the leaves. Each path occupies a line, with all the numbers separated by a space, and no extra space at the beginning or the end of the line. The paths must be printed in the following order: for each node in the tree, all the paths in its right subtree must be printed before those in its left subtree.

Finally print in a line Max Heap if it is a max heap, or Min Heap for a min heap, or Not Heap if it is not a heap at all.

Sample Input 1:

8
98 72 86 60 65 12 23 50

Sample Output 1:

98 86 23
98 86 12
98 72 65
98 72 60 50
Max Heap

Sample Input 2:

8
8 38 25 58 52 82 70 60

Sample Output 2:

8 25 70
8 25 82
8 38 52
8 38 58 60
Min Heap

Sample Input 3:

8
10 28 15 12 34 9 8 56

Sample Output 3:

10 15 8
10 15 9
10 28 34
10 28 12 56
Not Heap

題意

這道題是給出層次遍歷的完全二叉樹序列,要求從右至左輸出所有根節點到葉子節點的路徑,並判斷是否是大根堆或者小根堆

由於是完全二叉樹,所以陣列下標就可以確定節點在樹中的位置,並且節點數目確定了路徑的總數,路徑總數=節點數/2+節點數%2。我的想法是從右到左找到所有葉子節點,然後葉子節點下標迴圈/2直到下標為1(根節點)。設定兩個標誌變數flagMax, flagMin,初始值都為1,如果不滿足條件就將標記變數置0,最後判斷一下輸出結果就可以了。

從右至左找葉子節點,首先假設是一棵滿二叉樹,那麼從1開始編號,最右邊的葉子節點下標是2d-1(d表示樹的深度),如果2d-1>n,說明沒有該節點,判斷2d- 2是否大於n,如果也大於n,說明最右邊的葉子節點是上一層的最右邊節點,即(2d - 1)/2。然後按照這個規則找到所有葉子節點。

求路徑的時候是從葉子節點到根節點儲存的,跟路徑順序是相反的,所以採用棧來儲存,這樣輸出的時候就是正常的路徑順序。

Code

#include <stdio.h>
#include <vector>
#include <stack>
#include <math.h>
using namespace std;

int main(){
    int n, c = 1, l = 0;
    scanf("%d",&n);
    int key[n+1];
    for(int i = 1; i <= n; i++)
        scanf("%d", &key[i]);
    while(c < n + 1){ // 求完全二叉樹的深度
        c *= 2;
        l++;
    }

    int num = n / 2 + n % 2; //路徑總數
    vector<vector<int>> res;
    int flagMax = 1, flagMin = 1, max = pow(2, l) - 1; // max是深度為l的滿二叉樹節點的最大下標
    int leaf; // 葉子節點的下標
    // 找到最右邊的葉子節點
    if(max > n && max - 1 > n) leaf = max / 2;
    else if(max == n) leaf = max;
    else if(max - 1 == n) leaf = max - 1;

    for(int i = 1; i <= num; i++){
        stack<int> route;
        int root = leaf;
        while(root != 0){
            route.push(key[root]);
            root /= 2;
        }

        vector<int> tmp;
        int size = route.size();
        int maxr = key[1], minr = key[1];
        while(!route.empty()){
            int t = route.top();
            if(t > maxr) flagMax = 0;
            if(t < minr) flagMin = 0;
            if(size != 1) printf("%d ", t);
            else printf("%d\n", t);
            tmp.push_back(t);
            maxr = t; minr = t;
            route.pop();
            size--;
        }

        res.push_back(tmp);
        // 找下一個葉子節點下標
        leaf--;
        if(leaf * 2 + 1 == n) leaf = leaf * 2 + 1;
        else if(leaf * 2 == n) leaf = leaf * 2;
    }

    if(flagMax == 0 && flagMin == 0) printf("Not Heap\n");
    else if(flagMax == 1) printf("Max Heap\n");
    else printf("Min Heap\n");
    return 0;
}