1. 程式人生 > >Arbitrage【最短路——Floyd】

Arbitrage【最短路——Floyd】

Arbitrage

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.  Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not. 

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.  Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format "Case case: Yes" respectively "Case case: No".

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

題目大意:第一行輸入一個整數n,代表有n種不同的貨幣,其下n行輸入貨幣的名稱,再輸入一個整數m,其下m行每行分為三部分,代表貨幣s1換成貨幣s2的匯率。

解決方法:將每一種貨幣當做一個點,貨幣的交換當成線,只需判斷在這個圖中是否存在正邊權即可。

AC程式碼:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <map>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <set>
#include <utility>
using namespace std;
typedef long long ll;
#define inf 0x3f3f3f3f
#define rep(i,l,r) for(int i=l;i<=r;i++)
#define lep(i,l,r) for(int i=l;i>=r;i--)
#define ms(arr) memset(arr,0,sizeof(arr))
//priority_queue<int,vector<int> ,greater<int> >q;
const int maxn = (int)1e3 + 5;
const ll mod = 1e9+7;
double mapp[maxn][maxn];
double dist[maxn];
int n,ma;
bool floyd(int s)
{
	dist[s]=1.0;
	rep(i,1,n) {
		rep(j,1,n) {
			if(dist[j]<dist[i]*mapp[i][j])
				dist[j]=dist[i]*mapp[i][j];
		}
	}
	rep(i,1,n) {
		rep(j,1,n) {
			if(dist[j]<dist[i]*mapp[i][j])
			{
				return true;
			}
		}
	}
	return false;
}
int main() 
{
    //freopen("in.txt", "r", stdin);
    //freopen("out.txt", "w", stdout);
    ios::sync_with_stdio(0),cin.tie(0);
    int cnt=0;
    while(cin>>n&&n)
    {
    	cnt++;
    	map<string,int>m;
    	string s;
    	rep(i,1,n) {
    		cin>>s;
    		m[s]=i;
    	}
    	ms(mapp);
    	cin>>ma;
    	double nape;
    	string s1,s2;
    	for(int i=1;i<=ma;i++)
    	{
    		cin>>s1>>nape>>s2;
    		if(mapp[m[s1]][m[s2]]<nape)
    			mapp[m[s1]][m[s2]]=nape;
    	}
    	bool flag=floyd(1);
    	cout<<"Case "<<cnt<<": ";
    	if(flag)
    		cout<<"Yes"<<endl;
    	else
    		cout<<"No"<<endl;
    }
    return 0;
}