1. 程式人生 > >Apple Catching【動態規劃-dp】

Apple Catching【動態規劃-dp】

Apple Catching

It is a little known fact that cows love apples. Farmer John has two apple trees (which are conveniently numbered 1 and 2) in his field, each full of apples. Bessie cannot reach the apples when they are on the tree, so she must wait for them to fall. However, she must catch them in the air since the apples bruise when they hit the ground (and no one wants to eat bruised apples). Bessie is a quick eater, so an apple she does catch is eaten in just a few seconds.  Each minute, one of the two apple trees drops an apple. Bessie, having much practice, can catch an apple if she is standing under a tree from which one falls. While Bessie can walk between the two trees quickly (in much less than a minute), she can stand under only one tree at any time. Moreover, cows do not get a lot of exercise, so she is not willing to walk back and forth between the trees endlessly (and thus misses some apples).  Apples fall (one each minute) for T (1 <= T <= 1,000) minutes. Bessie is willing to walk back and forth at most W (1 <= W <= 30) times. Given which tree will drop an apple each minute, determine the maximum number of apples which Bessie can catch. Bessie starts at tree 1.

Input

* Line 1: Two space separated integers: T and W  * Lines 2..T+1: 1 or 2: the tree that will drop an apple each minute.

Output

* Line 1: The maximum number of apples Bessie can catch without walking more than W times.

Sample Input

7 2
2
1
1
2
2
1
1

Sample Output

6

Hint

INPUT DETAILS:  Seven apples fall - one from tree 2, then two in a row from tree 1, then two in a row from tree 2, then two in a row from tree 1. Bessie is willing to walk from one tree to the other twice.  OUTPUT DETAILS:  Bessie can catch six apples by staying under tree 1 until the first two have dropped, then moving to tree 2 for the next two, then returning back to tree 1 for the final two.

題目大意:開始時站在樹1下,第一行輸入兩個整數n,k,下面的n行代表在1到n秒內每次是哪棵數掉落蘋果,且人在兩棵樹之間可以移動,但最多隻能移動k次,問最多能接到幾個蘋果。

解決方法:dp[i][j]表示的是第i秒移動j次後能接到的最大蘋果數,dp[i][j]=max(dp[i-1][j],dp[i-1][j-1])。

AC程式碼:

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdlib>
#include <cstring>
#include <map>
#include <stack>
#include <queue>
#include <vector>
#include <bitset>
#include <set>
using namespace std;
typedef long long ll;
#define inf 0x3f3f3f3f
#define rep(i,l,r) for(int i=l;i<=r;i++)
#define lep(i,l,r) for(int i=l;i>=r;i--)
#define ms(arr) memset(arr,0,sizeof(arr))
//priority_queue<int,vector<int> ,greater<int> >q;
const int maxn = (int)1e3 + 5;
const ll mod = 1e9+7;
int arr[maxn];
int dp[maxn][maxn];
int main() 
{
    //freopen("in.txt", "r", stdin);
    //freopen("out.txt", "w", stdout);
    ios::sync_with_stdio(0),cin.tie(0);
    int t,m;
    cin>>t>>m;
    rep(i,1,t) {
        cin>>arr[i];
    }
    int ans=-1;
    for(int i=1;i<=t;i++)
    {
        for(int j=0;j<=m;j++)
        {
            if(j==0)
            {
                if(arr[i]==1)
                    dp[i][j]=dp[i-1][j]+1;    //初始化當一次也不移動時時第i秒的dp
            }
            else
            {
                dp[i][j]=max(dp[i-1][j],dp[i-1][j-1]);    
                if(j%2==0&&arr[i]==1)   //當前在第一棵樹下且第一棵樹掉落蘋果
                    dp[i][j]++;
                else if(j%2==1&&arr[i]==2)    //當前在第二棵樹下且第二棵樹掉落蘋果
                    dp[i][j]++;
            }
            ans=max(dp[i][j],ans);
        }
    }
    cout<<ans<<endl;
    return 0;
}