1. 程式人生 > >Robberies HDU

Robberies HDU

The aspiring Roy the Robber has seen a lot of American movies, and knows that the bad guys usually gets caught in the end, often because they become too greedy. He has decided to work in the lucrative business of bank robbery only for a short while, before retiring to a comfortable job at a university. 

For a few months now, Roy has been assessing the security of various banks and the amount of cash they hold. He wants to make a calculated risk, and grab as much money as possible.  His mother, Ola, has decided upon a tolerable probability of getting caught. She feels that he is safe enough if the banks he robs together give a probability less than this.

Input

The first line of input gives T, the number of cases. For each scenario, the first line of input gives a floating point number P, the probability Roy needs to be below, and an integer N, the number of banks he has plans for. Then follow N lines, where line j gives an integer Mj and a floating point number Pj .  Bank j contains Mj millions, and the probability of getting caught from robbing it is Pj .

Output

For each test case, output a line with the maximum number of millions he can expect to get while the probability of getting caught is less than the limit set.  Notes and Constraints  0 < T <= 100  0.0 <= P <= 1.0  0 < N <= 100  0 < Mj <= 100  0.0 <= Pj <= 1.0  A bank goes bankrupt if it is robbed, and you may assume that all probabilities are independent as the police have very low funds.

Sample Input

3 0.04 3 1 0.02 2 0.03 3 0.05 0.06 3 2 0.03 2 0.03 3 0.05 0.10 3 1 0.03 2 0.02 3 0.05

Sample Output

2 4 6

題意:

先給出測試樣例的個數t,每個測試樣例第一行是總被抓概率P(最後求得的總概率必須小於他,否則就會被抓),然後是想搶的銀行數n。然後n行,每行分別是該銀行能搶的錢數m和被抓的概率p。求不被抓到的概率內可搶到的最大的金錢數

因為題目給出的是被抓的概率,那麼我們就轉換為安全概率1-p,然後使用0-1揹包。dp[i]就是搶到錢數是i時候的安全概率。最後求出不超過總安全概率(1-P)的最多的i數。

程式碼:

#include<iostream>
#include<cstring>
#include<cmath>
#include<cstdio>
#include<algorithm>
using namespace std;
double dp[105*105];
struct node{
	int money;  //錢數 
	double p;   //安全的概率 
}bank[110];
int main()
{
	int t,n;
	double P;
	scanf("%d",&t);
	while(t--)
	{
		int m=0;
		scanf("%lf%d",&P,&n);  //被抓的概率,n個銀行 
		P=1.0-P; //安全概率 
		for(int i=1;i<=n;i++)
		{
			scanf("%d%lf",&bank[i].money,&bank[i].p);
			bank[i].p=1.0-bank[i].p;
			m+=bank[i].money;   //所有銀行錢 
		}
		memset(dp,0,sizeof(dp));
		dp[0]=1; //不搶的時候,安全概率是1 
		for(int i=1;i<=n;i++)
		{
			for(int j=m;j>=bank[i].money;j--)
			{
				dp[j]=max(dp[j],dp[j-bank[i].money]*bank[i].p);//dp[j]:搶到j錢的安全概率 
			}
		}
		for(int i=m;i>=0;i--)
		{
			if(dp[i]>P)
			{
				printf("%d\n",i);
				break;
			}
		} 
	}
	return 0;
 }