1. 程式人生 > >POJ1579 HDU1331 HDU1579 ZOJ1168 Function Run Fun【記憶化遞迴】

POJ1579 HDU1331 HDU1579 ZOJ1168 Function Run Fun【記憶化遞迴】

Function Run Fun

Description

We all love recursion! Don't we?

Consider a three-parameter recursive function w(a, b, c):

if a <= 0 or b <= 0 or c <= 0, then w(a, b, c) returns:
1

if a > 20 or b > 20 or c > 20, then w(a, b, c) returns:
w(20, 20, 20)

if a < b and b < c, then w(a, b, c) returns:
w(a, b, c-1) + w(a, b-1, c-1) - w(a, b-1, c)

otherwise it returns:
w(a-1, b, c) + w(a-1, b-1, c) + w(a-1, b, c-1) - w(a-1, b-1, c-1)

This is an easy function to implement. The problem is, if implemented directly, for moderate values of a, b and c (for example, a = 15, b = 15, c = 15), the program takes hours to run because of the massive recursion.

Input

The input for your program will be a series of integer triples, one per line, until the end-of-file flag of -1 -1 -1. Using the above technique, you are to calculate w(a, b, c) efficiently and print the result.

Output

Print the value for w(a,b,c) for each triple.

Sample Input

1 1 1
2 2 2
10 4 6
50 50 50
-1 7 18
-1 -1 -1

Sample Output

w(1, 1, 1) = 2
w(2, 2, 2) = 4
w(10, 4, 6) = 523
w(50, 50, 50) = 1048576
w(-1, 7, 18) = 1

Source

Pacific Northwest 1999

問題連結POJ1579 HDU1331 HDU1579 ZOJ1168 Function Run Fun
問題描述:(略)
問題分析
    這是一個遞迴函式計算問題,最怕的是重複計算。
    該題的絕大多數解法是打表法,然而遞迴函式計算可以採用記憶化遞迴進行計算。打表法則需要事先把所有的可能都算出來;記憶化遞迴也打表,但只計算必要的項,有可能計算量更少一些。
程式說明:(略)
參考連結:(略)
題記:(略)

AC的C語言程式如下:

/* POJ1579 HDU1331 HDU1579 ZOJ1168 Function Run Fun */

#include <stdio.h>
#include <string.h>

#define N 20
int f[N + 1][N + 1][N + 1];

int w(int a, int b, int c)
{
    if(a <= 0 || b <= 0 || c <= 0) return 1;
    else if(a > N || b > N || c > N) return w(N, N, N);
    else if(f[a][b][c]) return f[a][b][c];
    else if(a < b && b < c) return f[a][b][c] = w(a, b, c - 1) + w(a, b - 1, c - 1) - w(a, b - 1, c);
    else return f[a][b][c] = w(a - 1, b, c) + w(a - 1, b - 1, c) + w(a - 1, b, c - 1) - w(a - 1, b - 1, c - 1);
}

int main(void)
{
    memset(f, 0, sizeof(f));

    int a, b, c;
    while(scanf("%d%d%d", &a, &b, &c) != EOF) {
        if(a == -1 && b == -1 && c == -1) return 0;
        printf("w(%d, %d, %d) = %d\n", a, b, c, w(a,b,c));
    }

    return 0;
}