1. 程式人生 > >poj 1611 The Suspects 並查集

poj 1611 The Suspects 並查集

The Suspects

Time Limit: 1000MS Memory Limit: 20000K
Total Submissions: 49056 Accepted: 23475

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

題意如下:

就是0同學是感染者, 所有與0同學一組的都會被感染, 求感人者的個數。

思路:
此題的意思就是求0所在的集合的元素的個數,前天剛剛瞭解的並查集彷彿有了用處,此題可以將每組的兩兩弄到一個集合, 最後統計與0一個集合的同學數。

程式碼如下:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
int n,m;
int a[30005];
int findd(int son)
{
    int temp=son;
    while(a[temp]!=temp)
          temp=a[temp];
    while (temp!=son)
    {
        int ttemp=a[son];
        a[son]=temp;
        son=ttemp;
    }
    return temp;
}
int main()
{
    while (scanf("%d%d",&n,&m)!=EOF&&(n||m))
    {
        for (int i=0;i<n;i++)
            a[i]=i;
        int sum=0;
        for (int i=0;i<m;i++)
        {
            int k;
            scanf("%d",&k);
            int flag=0;
            int b[30005];
            for (int j=0;j<k;j++)
            {
                scanf("%d",&b[j]);
                if(j)
                 {
                     int x1=findd(b[j-1]);
                     int x2=findd(b[j]);
                     if(x1!=x2)
                        a[x1]=x2;
                 }
            }
        }
        for (int i=0;i<n;i++)
            if(findd(0)==findd(i))
                 sum++;
        printf("%d\n",sum);
    }
    return 0;
}