1. 程式人生 > >poj 1426 Find The Multiple (簡單搜尋dfs)

poj 1426 Find The Multiple (簡單搜尋dfs)

題目:

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input

The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output

For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111

 

題意:

        本題要找出數m,m是隻有0和1構成的十進位制數,並且是n的倍數,若有多個答案,輸出任意一個就可以。

 

題解:

        經過思考會發現m最大不會超過unsigned long long 的範圍,所以用unsigned long long儲存就可以,接下來就是深搜就ok。

 

程式碼:

#include <iostream>

using namespace std;
unsigned long long ans;
bool f;

void dfs(unsigned long long s,int n,int k)
{
    if(f) return ;
    if(s%n==0) {ans=s;f=true; return ;}
    if(k==19) return ;        //如果k超過19就不在unsigned long long的範圍內了
    dfs(s*10,n,k+1);
    dfs(s*10+1,n,k+1);
    return ;
}

int main()
{
    int n;
    while(cin>>n,n)
    {
        ans=0;
        f=false;
        dfs(1,n,0);
        cout<<ans<<endl;
    }
    return 0;
}