1. 程式人生 > >hdu 1241 Oil Deposits (簡單搜尋)

hdu 1241 Oil Deposits (簡單搜尋)

題目:

  The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid. InputThe input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.
OutputFor each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input
1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5 
****@
*@@*@
*@**@
@@@*@
@@**@
0 0 
Sample Output
0
1
2
2

 

題解:

  逐個遍歷,遇到‘@’就深搜它的周圍,逐層深搜,直到把相連的所有@都變成*。

 

程式碼:

 

#include <iostream>

using namespace std;
char a[101][101];
int n,m,sum=0;
void dfs(int i,int j){
    if(a[i][j]!='@'||i<0||j<0||i>=m||j>=n) return;
    else{
        a[i][j]='*';
        dfs(i
-1, j-1); dfs(i-1, j); dfs(i-1, j+1); dfs(i, j-1); dfs(i, j+1); dfs(i+1, j-1); dfs(i+1, j); dfs(i+1, j+1); } } int main() { int i,j; while(cin>>m>>n){ sum=0; if(n==0||m==0) break; for(i=0;i<m;i++)
for(j=0;j<n;j++) cin>>a[i][j]; for(i=0;i<m;i++) for(j=0;j<n;j++){ if(a[i][j]=='@'){ dfs(i,j); sum++; } } cout<<sum<<endl; } return 0; }