1. 程式人生 > >MPLS-8 誇(國)運營商MPLS-VPN配置

MPLS-8 誇(國)運營商MPLS-VPN配置

一、跨運營商的MPLS-VPN

拓撲:中美運營商之間使用IGP協議(俗稱背靠背模式),本拓撲使用eigrp連線雙方ISP(下一篇使用EBGP方式,更加實用),分別為客戶huawei提供VPN服務

目標客戶內網互通,並不能影響訪問Internet網路,由於中美ISP之間沒有baidu路由,因此無法通過路由重分發的方式學習到對方的ipv4 unicast路由,只能通過靜態路由設定

重點是PE2和PE3之間的IGP與BGP重分發以及子介面分離vpn和ipv4 internet流量

配置

CE1#show run
Building configuration...
!
interface Loopback0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface FastEthernet0/0.1
 encapsulation dot1Q 10
 ip address 12.1.1.1 255.255.255.0
!
interface FastEthernet0/0.2
 encapsulation dot1Q 20
 ip address 100.1.1.1 255.255.255.0
 ip nat outside
 ip virtual-reassembly
!
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 network 192.168.1.0
 neighbor 12.1.1.2 remote-as 100
 neighbor 12.1.1.2 allowas-in 2
 no auto-summary
!
ip route 0.0.0.0 0.0.0.0 100.1.1.2
!
ip nat inside source list nat interface FastEthernet0/0.2 overload
!
ip access-list extended nat
 deny   ip 192.168.1.0 0.0.0.255 172.16.1.0 0.0.0.255
 permit ip any any
CE1#

============================================

PE1#show run
ip cef
!
ip vrf huawei
 rd 1:1   
 route-target export 1:100
 route-target import 100:1
!
mpls label range 100 199
mpls label protocol ldp
mpls ldp router-id Loopback0 force
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
!         
interface FastEthernet0/0.1
 encapsulation dot1Q 10
 ip vrf forwarding huawei
 ip address 12.1.1.2 255.255.255.0
!
interface FastEthernet0/0.2
 encapsulation dot1Q 20
 ip address 100.1.1.2 255.255.255.0
!
interface FastEthernet0/1
 ip address 23.1.1.1 255.255.255.0
 duplex auto
 speed auto
 mpls ip
!
router ospf 100
 router-id 2.2.2.2
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 12.1.1.0 0.0.0.255 area 0
 network 23.1.1.0 0.0.0.255 area 0
!
router bgp 100
 bgp log-neighbor-changes
 neighbor 4.4.4.4 remote-as 100
 neighbor 4.4.4.4 update-source Loopback0
 !
 address-family ipv4
  neighbor 4.4.4.4 activate
  no auto-summary
  no synchronization
  network 100.1.1.0 mask 255.255.255.0
 exit-address-family
 !
 address-family vpnv4
  neighbor 4.4.4.4 activate
  neighbor 4.4.4.4 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf huawei
  neighbor 12.1.1.1 remote-as 200
  neighbor 12.1.1.1 activate
  no synchronization
 exit-address-family
PE1#

=====================================================

P1#show run
ip cef
!
mpls label range 200 299
mpls label protocol ldp
mpls ldp router-id Loopback0 force
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255
!
interface FastEthernet0/0
 ip address 23.1.1.2 255.255.255.0
 duplex auto
 speed auto
 mpls ip  
!
interface FastEthernet0/1
 ip address 34.1.1.1 255.255.255.0
 duplex auto
 speed auto
 mpls ip
!
router ospf 100
 router-id 3.3.3.3
 log-adjacency-changes
 network 3.3.3.3 0.0.0.0 area 0
 network 23.1.1.0 0.0.0.255 area 0
 network 34.1.1.0 0.0.0.255 area 0
P1#  

==============================================

PE2#show run
ip cef
ip vrf huawei
 rd 1:1   
 route-target export 100:1
 route-target import 1:100
!
mpls label range 400 499
mpls label protocol ldp
mpls ldp router-id Loopback0 force
!
interface Loopback0
 ip address 4.4.4.4 255.255.255.255
!
interface FastEthernet0/0
 ip address 34.1.1.2 255.255.255.0
 duplex auto
 speed auto
 mpls ip
!
interface FastEthernet0/1
 ip address 45.1.1.1 255.255.255.0
 speed auto
 full-duplex
!
interface FastEthernet0/1.1
 encapsulation dot1Q 10
 ip vrf forwarding huawei
 ip address 45.1.1.1 255.255.255.0
!
interface FastEthernet0/1.2
 encapsulation dot1Q 20
 ip address 200.1.1.1 255.255.255.0
!
interface FastEthernet1/0
 no switchport
 ip address 53.128.60.1 255.255.255.0
!
router eigrp 100
 redistribute ospf 100 metric 10000 100 255 1 1500
 network 34.1.1.0 0.0.0.255
 network 53.128.60.0 0.0.0.255
 network 200.1.1.0
 no auto-summary
 !
 address-family ipv4 vrf huawei
  redistribute bgp 100 metric 10000 100 255 1 1500
  network 45.1.1.0 0.0.0.255
  no auto-summary
  autonomous-system 200
 exit-address-family
!
router ospf 100
 router-id 4.4.4.4
 log-adjacency-changes
 network 4.4.4.4 0.0.0.0 area 0
 network 34.1.1.0 0.0.0.255 area 0
!
router bgp 100
 bgp log-neighbor-changes
 neighbor 2.2.2.2 remote-as 100
 neighbor 2.2.2.2 update-source Loopback0
 !
 address-family ipv4
  neighbor 2.2.2.2 activate
  no auto-summary
  no synchronization
  network 53.128.60.0 mask 255.255.255.0
  network 53.128.61.5 mask 255.255.255.255
 exit-address-family
 !
 address-family vpnv4
  neighbor 2.2.2.2 activate
  neighbor 2.2.2.2 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf huawei
  redistribute eigrp 200
  no synchronization
 exit-address-family
!
ip forward-protocol nd
ip route 53.128.61.5 255.255.255.255 53.128.60.2
ip route 101.1.1.0 255.255.255.0 200.1.1.2 name to_CE2
!
PE2#

==============================================

Baidu#show run | sec int
interface Loopback0
 ip address 53.128.61.5 255.255.255.255
interface FastEthernet0/0
 ip address 53.128.60.2 255.255.255.0
 duplex auto
 speed auto

Baidu#show run | sec route
ip route 0.0.0.0 0.0.0.0 53.128.60.1

=============================================

PE3#show run
!
ip cef
!
ip vrf huawei
 rd 1:1   
 route-target export 1:100
 route-target import 100:1
!
mpls label range 500 599
mpls label protocol ldp
mpls ldp router-id Loopback0 force
!
interface Loopback0
 ip address 5.5.5.5 255.255.255.255
!         
interface FastEthernet0/0
 ip address 45.1.1.2 255.255.255.0
 speed auto
 full-duplex
!
interface FastEthernet0/0.1
 encapsulation dot1Q 10
 ip vrf forwarding huawei
 ip address 45.1.1.2 255.255.255.0
!
interface FastEthernet0/0.2
 encapsulation dot1Q 20
 ip address 200.1.1.2 255.255.255.0
!
interface FastEthernet0/1
 ip address 56.1.1.1 255.255.255.0
 duplex auto
 speed auto
 mpls ip
!
router eigrp 100
 redistribute ospf 200 metric 10000 100 255 1 1500
 redistribute bgp 300 metric 10000 100 255 1 1500
 network 56.1.1.0 0.0.0.255
 network 200.1.1.0
 no auto-summary
 !
 address-family ipv4 vrf huawei
  redistribute bgp 300 metric 10000 100 255 1 1500
  network 45.1.1.0 0.0.0.255
  no auto-summary
  autonomous-system 200
 exit-address-family
!         
router ospf 200
 router-id 5.5.5.5
 log-adjacency-changes
 network 5.5.5.5 0.0.0.0 area 0
 network 56.1.1.0 0.0.0.255 area 0
!
router bgp 300
 bgp log-neighbor-changes
 neighbor 7.7.7.7 remote-as 300
 neighbor 7.7.7.7 update-source Loopback0
 !
 address-family ipv4
  redistribute eigrp 100
  neighbor 7.7.7.7 activate
  neighbor 7.7.7.7 next-hop-self
  no auto-summary
  no synchronization
  network 53.128.61.5 mask 255.255.255.255
 exit-address-family
 !
 address-family vpnv4
  neighbor 7.7.7.7 activate
  neighbor 7.7.7.7 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf huawei
  redistribute eigrp 200
  no synchronization
 exit-address-family
!
ip forward-protocol nd
ip route 53.128.61.5 255.255.255.255 200.1.1.1 name to_baidu

PE3#     

=======================================================

P2#show run
ip cef
!
mpls label range 600 699
mpls label protocol ldp
mpls ldp router-id Loopback0 force
!
interface Loopback0
 ip address 6.6.6.6 255.255.255.255
!
interface FastEthernet0/0
 ip address 56.1.1.2 255.255.255.0
 duplex auto
 speed auto
 mpls ip  
!
interface FastEthernet0/1
 ip address 67.1.1.1 255.255.255.0
 duplex auto
 speed auto
 mpls ip
!
router ospf 200
 router-id 6.6.6.6
 log-adjacency-changes
 network 6.6.6.6 0.0.0.0 area 0
 network 56.1.1.0 0.0.0.255 area 0
 network 67.1.1.0 0.0.0.255 area 0
!
P2# 

==============================================

PE4#show run
ip cef
!
ip vrf huawei
 rd 1:1   
 route-target export 100:1
 route-target import 1:100
!
no ip domain lookup
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
mpls label range 700 799
mpls label protocol ldp
mpls ldp router-id Loopback0 force    
!
interface Loopback0
 ip address 7.7.7.7 255.255.255.255
!         
interface FastEthernet0/0
 ip address 67.1.1.2 255.255.255.0
 duplex auto
 speed auto
 mpls ip
!
interface FastEthernet0/1.1
 encapsulation dot1Q 10
 ip vrf forwarding huawei
 ip address 89.1.1.1 255.255.255.0
!
interface FastEthernet0/1.2
 encapsulation dot1Q 20
 ip address 101.1.1.1 255.255.255.0
!
router ospf 200
 router-id 7.7.7.7
 log-adjacency-changes
 network 7.7.7.7 0.0.0.0 area 0
 network 67.1.1.0 0.0.0.255 area 0
!
router bgp 300
 bgp log-neighbor-changes
 neighbor 5.5.5.5 remote-as 300
 neighbor 5.5.5.5 update-source Loopback0
 !
 address-family ipv4
  neighbor 5.5.5.5 activate
  no auto-summary
  no synchronization
  network 101.1.1.0 mask 255.255.255.0
 exit-address-family
 !
 address-family vpnv4
  neighbor 5.5.5.5 activate
  neighbor 5.5.5.5 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf huawei
  neighbor 89.1.1.2 remote-as 200
  neighbor 89.1.1.2 activate
  no synchronization
 exit-address-family
!
PE4#

CE2#show run
ip cef
!
interface Loopback0
 ip address 172.16.1.1 255.255.255.0
 ip nat inside
 ip virtual-reassembly
!
interface FastEthernet0/0.1
 encapsulation dot1Q 10
 ip address 89.1.1.2 255.255.255.0
!
interface FastEthernet0/0.2
 encapsulation dot1Q 20
 ip address 101.1.1.2 255.255.255.0
 ip nat outside
 ip virtual-reassembly
!
router bgp 200
 bgp log-neighbor-changes
 neighbor 89.1.1.1 remote-as 300
 !
 address-family ipv4
  neighbor 89.1.1.1 activate
  no auto-summary
  no synchronization
  network 172.16.1.0 mask 255.255.255.0
 exit-address-family
!
ip route 0.0.0.0 0.0.0.0 101.1.1.1
!
ip nat inside source list nat interface FastEthernet0/0.2 overload
!
ip access-list extended nat
 deny   ip 172.16.1.0 0.0.0.255 192.168.1.0 0.0.0.255
 permit ip any any
!
CE2#

=====================================================

CE1#ping 172.16.1.1 source 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 172.16.1.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.1 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 52/80/100 ms
CE1#ping 53.128.61.5 source 192.168.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 53.128.61.5, timeout is 2 seconds:
Packet sent with a source address of 192.168.1.1 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 28/47/84 ms
CE1#

----------------------------------------------------------------------------------------------------

CE2#ping 192.168.1.1 source 172.16.1.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.1, timeout is 2 seconds:
Packet sent with a source address of 172.16.1.1 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/65/76 ms
CE2#ping 53.128.61.5 souurce 172.16.1.1
                        ^
% Invalid input detected at '^' marker.

CE2#ping 53.128.61.5 source 172.16.1.1 

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 53.128.61.5, timeout is 2 seconds:
Packet sent with a source address of 172.16.1.1 
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/52/68 ms
CE2#

----------------------------------------------------------------------------------------------------

PE2#show ip route vrf
% Incomplete command.

PE2#show ip route vrf huawei

Routing Table: huawei
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
D EX    172.16.1.0 [170/307200] via 45.1.1.2, 1d04h, FastEthernet0/1.1
B    192.168.1.0/24 [200/0] via 2.2.2.2, 3d08h
     45.0.0.0/24 is subnetted, 1 subnets
C       45.1.1.0 is directly connected, FastEthernet0/1.1
PE2#show ip rout
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     34.0.0.0/24 is subnetted, 1 subnets
C       34.1.1.0 is directly connected, FastEthernet0/0
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/21] via 34.1.1.1, 2d01h, FastEthernet0/0
     100.0.0.0/24 is subnetted, 1 subnets
B       100.1.1.0 [200/0] via 2.2.2.2, 2d00h
     3.0.0.0/32 is subnetted, 1 subnets
O       3.3.3.3 [110/11] via 34.1.1.1, 2d01h, FastEthernet0/0
     101.0.0.0/24 is subnetted, 1 subnets
S       101.1.1.0 [1/0] via 200.1.1.2
     4.0.0.0/32 is subnetted, 1 subnets
C       4.4.4.4 is directly connected, Loopback0
     5.0.0.0/32 is subnetted, 1 subnets
D EX    5.5.5.5 [170/307200] via 200.1.1.2, 1d04h, FastEthernet0/1.2
C    200.1.1.0/24 is directly connected, FastEthernet0/1.2
     53.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C       53.128.60.0/24 is directly connected, FastEthernet1/0
S       53.128.61.5/32 [1/0] via 53.128.60.2
     6.0.0.0/32 is subnetted, 1 subnets
D EX    6.6.6.6 [170/307200] via 200.1.1.2, 1d04h, FastEthernet0/1.2
     23.0.0.0/24 is subnetted, 1 subnets
O       23.1.1.0 [110/20] via 34.1.1.1, 2d01h, FastEthernet0/0
     67.0.0.0/24 is subnetted, 1 subnets
D EX    67.1.1.0 [170/307200] via 200.1.1.2, 1d04h, FastEthernet0/1.2
     7.0.0.0/32 is subnetted, 1 subnets
D EX    7.7.7.7 [170/307200] via 200.1.1.2, 1d04h, FastEthernet0/1.2
     56.0.0.0/24 is subnetted, 1 subnets
D       56.1.1.0 [90/307200] via 200.1.1.2, 1d04h, FastEthernet0/1.2
     45.0.0.0/24 is subnetted, 1 subnets
C       45.1.1.0 is directly connected, FastEthernet0/1
PE2# 

-----------------------------------------------------------------------------------------------------

PE3#show ip rout vrf huawei

Routing Table: huawei
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
B       172.16.1.0 [200/0] via 7.7.7.7, 1d04h
D EX 192.168.1.0/24 [170/307200] via 45.1.1.1, 1d04h, FastEthernet0/0.1
     45.0.0.0/24 is subnetted, 1 subnets
C       45.1.1.0 is directly connected, FastEthernet0/0.1
PE3#show ip rout
PE3#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     34.0.0.0/24 is subnetted, 1 subnets
D       34.1.1.0 [90/307200] via 200.1.1.1, 1d04h, FastEthernet0/0.2
     2.0.0.0/32 is subnetted, 1 subnets
D EX    2.2.2.2 [170/307200] via 200.1.1.1, 1d04h, FastEthernet0/0.2
     3.0.0.0/32 is subnetted, 1 subnets
D EX    3.3.3.3 [170/307200] via 200.1.1.1, 1d04h, FastEthernet0/0.2
     101.0.0.0/24 is subnetted, 1 subnets
B       101.1.1.0 [200/0] via 7.7.7.7, 23:27:34
     4.0.0.0/32 is subnetted, 1 subnets
D EX    4.4.4.4 [170/307200] via 200.1.1.1, 1d04h, FastEthernet0/0.2
     5.0.0.0/32 is subnetted, 1 subnets
C       5.5.5.5 is directly connected, Loopback0
C    200.1.1.0/24 is directly connected, FastEthernet0/0.2
     53.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
D       53.128.60.0/24 [90/284160] via 200.1.1.1, 1d04h, FastEthernet0/0.2
S       53.128.61.5/32 [1/0] via 200.1.1.1
     6.0.0.0/32 is subnetted, 1 subnets
O       6.6.6.6 [110/11] via 56.1.1.2, 2d01h, FastEthernet0/1
     23.0.0.0/24 is subnetted, 1 subnets
D EX    23.1.1.0 [170/307200] via 200.1.1.1, 1d04h, FastEthernet0/0.2
     67.0.0.0/24 is subnetted, 1 subnets
O       67.1.1.0 [110/20] via 56.1.1.2, 2d01h, FastEthernet0/1
     7.0.0.0/32 is subnetted, 1 subnets
O       7.7.7.7 [110/21] via 56.1.1.2, 2d01h, FastEthernet0/1
     56.0.0.0/24 is subnetted, 1 subnets
C       56.1.1.0 is directly connected, FastEthernet0/1
     45.0.0.0/24 is subnetted, 1 subnets
C       45.1.1.0 is directly connected, FastEthernet0/0
PE3# 

---------------------------

PE1#show mpls forwarding-table 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
16     Untagged    192.168.1.0/24[V] 5310       Fa0/0.1    12.1.1.1     
17     201         4.4.4.4/32        0          Fa0/1      23.1.1.2     
18     Pop tag     3.3.3.3/32        0          Fa0/1      23.1.1.2     
19     Pop tag     34.1.1.0/24       0          Fa0/1      23.1.1.2     
PE1#

-----------------------------

P1#show mpls forwarding-table 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
200    Pop tag     2.2.2.2/32        497070     Fa0/0      23.1.1.1     
201    Pop tag     4.4.4.4/32        599886     Fa0/1      34.1.1.2     
P1#

--------------------------------

PE2#show mpls forwarding-table 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
400    200         2.2.2.2/32        0          Fa0/0      34.1.1.1     
401    Untagged    53.128.61.5/32    0          Fa1/0      53.128.60.2  
402    Pop tag     23.1.1.0/24       0          Fa0/0      34.1.1.1     
403    Pop tag     3.3.3.3/32        0          Fa0/0      34.1.1.1     
404    Untagged    56.1.1.0/24       0          Fa0/1.2    200.1.1.2    
405    Untagged    101.1.1.0/24      0          Fa0/1.2    200.1.1.2    
407    Untagged    5.5.5.5/32        0          Fa0/1.2    200.1.1.2    
408    Untagged    6.6.6.6/32        0          Fa0/1.2    200.1.1.2    
409    Untagged    67.1.1.0/24       0          Fa0/1.2    200.1.1.2    
410    Untagged    7.7.7.7/32        0          Fa0/1.2    200.1.1.2    
411    Aggregate   45.1.1.0/24[V]    0                                  
412    Untagged    172.16.1.0/24[V]  3540       Fa0/1.1    45.1.1.2     
PE2#

---------------------------------------

PE4#show mpls forwarding-table 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
700    Untagged    172.16.1.0/24[V]  4720       Fa0/1.1    89.1.1.2     
701    Pop tag     56.1.1.0/24       0          Fa0/0      67.1.1.1     
702    601         5.5.5.5/32        0          Fa0/0      67.1.1.1     
703    Pop tag     6.6.6.6/32        0          Fa0/0      67.1.1.1     
PE4#

------------------------------------------------------------

P2#show mpls forwarding-table 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
600    Pop tag     7.7.7.7/32        452244     Fa0/1      67.1.1.2     
601    Pop tag     5.5.5.5/32        565793     Fa0/0      56.1.1.1     
P2#

----------------------------------------------------------------

PE3#show mpls forwarding-table 
Local  Outgoing    Prefix            Bytes tag  Outgoing   Next Hop    
tag    tag or VC   or Tunnel Id      switched   interface              
500    Pop tag     67.1.1.0/24       0          Fa0/1      56.1.1.2     
501    600         7.7.7.7/32        0          Fa0/1      56.1.1.2     
502    Pop tag     6.6.6.6/32        0          Fa0/1      56.1.1.2     
503    Untagged    34.1.1.0/24       0          Fa0/0.2    200.1.1.1    
504    Untagged    53.128.61.5/32    0          Fa0/0.2    200.1.1.1    
506    Untagged    2.2.2.2/32        0          Fa0/0.2    200.1.1.1    
508    Untagged    3.3.3.3/32        0          Fa0/0.2    200.1.1.1    
509    Untagged    4.4.4.4/32        0          Fa0/0.2    200.1.1.1    
510    Untagged    23.1.1.0/24       0          Fa0/0.2    200.1.1.1    
511    Untagged    53.128.60.0/24    0          Fa0/0.2    200.1.1.1    
512    Aggregate   45.1.1.0/24[V]    0                                  
513    Untagged    192.168.1.0/24[V] 3540       Fa0/0.1    45.1.1.1     
PE3#