1. 程式人生 > >poj2184:cow exhibition

poj2184:cow exhibition

Description

"Fat and docile, big and dumb, they look so stupid, they aren't much 
fun..." 
- Cows with Guns by Dana Lyons 

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow. 

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative. 

Input

* Line 1: A single integer N, the number of cows 

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow. 

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0. 

Sample Input

5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output

8
可以看做一個01揹包問題,也是有幾頭牛,每頭牛有兩個屬性值,並且每頭牛要麼被選要麼不選,但是這裡的揹包的容量並不是固定的,可以想象成一個揹包必須裝滿的揹包問題,也就是說在初始化的時候除了容量為0的揹包初始化為0,其它的都初始化為負無窮大。同時,考慮到smartness值可能為負,所以要整體加上一個值,否則陣列索引為負越界。
#include <iostream>
#include<cstring>
#include<climits>
#include<algorithm>

using namespace std;

typedef struct Cow
{
    int s;
    int f;
}cow;


int main()
{
    int N;
    int i,s;
    int maxsum=0;
    int dp[200001];
    for(i=0;i<=200000;i++)//初始化的時候所有值初始化為負無窮大,這樣\
        dp[i]=INT_MIN;      //表示每個容量的揹包必須裝滿
    dp[100000]=0;

    cin>>N;
    cow *pcow=new cow[N];
    for(i=0;i<N;i++)
        cin>>pcow[i].s>>pcow[i].f;

    for(i=0;i<N;i++)
    {

        if(pcow[i].s>0)
        {
            for(s=200000;s>=pcow[i].s;s--)
                 if(dp[s-pcow[i].s]>INT_MIN)
                      dp[s]=max(dp[s],dp[s-pcow[i].s]+pcow[i].f);
        }
        else
        {
            for(s=0;s<200000+pcow[i].s;s++)
                if(dp[s-pcow[i].s]>INT_MIN)
                    dp[s]=max(dp[s],dp[s-pcow[i].s]+pcow[i].f);
        }

    }

    for(i=100000;i<=200000;i++)
    {
        if(dp[i]>=0)
            maxsum=max(maxsum,dp[i]+i-100000);

    }
    cout<<maxsum<<endl;
    delete[] pcow;
    return 0;
}