1. 程式人生 > >HDU 6063 RXD and math+(快速冪)+多校聯賽第三場

HDU 6063 RXD and math+(快速冪)+多校聯賽第三場



RXD and math

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 416    Accepted Submission(s): 210


Problem Description RXD is a good mathematician.
One day he wants to calculate:
i=1nkμ2(i)×nki
output the answer module 109+7.
1n,k1018
μ(n)=1(n=
1)

μ(n)=(1)k(n=p1p2pk)
μ(n)=0(otherwise)
p1,p2,p3pk are different prime numbers

Input There are several test cases, please keep reading until EOF.
There are exact 10000 cases.
For each test case, there are 2 numbers n,k.
Output For each test case, output "Case #x: y", which means the test case number and the answer.
Sample Input 10 10
Sample Output Case #1: 999999937
Source
Recommend liuyiding   |   We have carefully selected several similar problems for you:  
6066
 6065 6064 6063 6062  官方題解
注意到一個數字xx必然會被唯一表示成a^2\times ba2×b的形式.其中|\mu(b)| = 1μ(b)=1。 所以這個式子會把[1, n^k][1,nk]的每個整數恰好算一次. 所以答案就是n^knk,快速冪即可. 時間複雜度O(\log k)O(logk).
當時做題是想的是打表,到現在,也不知道怎麼推出了的, 正場比賽下來,求安慰
#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
using namespace std;
int main()
{
    long long n,k;
    int T=1;
    while(scanf("%lld%lld",&n,&k)!=EOF)
    {
        long long sum=1;
        n=n%1000000007;
        while(k)
        {
            if(k%2==0)
            {
                n=n*n%1000000007;
                k=k/2;
            }
            else
            {
                sum=(sum%1000000007)*(n%1000000007);
                sum=sum%1000000007;
                k--;
            }
        }

        printf("Case #%d: %lld\n",T++,sum);
    }
}