1. 程式人生 > >POJ - 3714 Raid (平面分治最小點對)

POJ - 3714 Raid (平面分治最小點對)

After successive failures in the battles against the Union, the Empire retreated to its last stronghold. Depending on its powerful defense system, the Empire repelled the six waves of Union's attack. After several sleepless nights of thinking, Arthur, General of the Union, noticed that the only weakness of the defense system was its energy supply. The system was charged by N

 nuclear power stations and breaking down any of them would disable the system.

The general soon started a raid to the stations by N special agents who were paradroped into the stronghold. Unfortunately they failed to land at the expected positions due to the attack by the Empire Air Force. As an experienced general, Arthur soon realized that he needed to rearrange the plan. The first thing he wants to know now is that which agent is the nearest to any power station. Could you, the chief officer, help the general to calculate the minimum distance between an agent and a station?

 

Input

The first line is a integer T representing the number of test cases.
Each test case begins with an integer N (1 ≤ N ≤ 100000).
The next N lines describe the positions of the stations. Each line consists of two integers X (0 ≤ X

 ≤ 1000000000) and Y (0 ≤ Y ≤ 1000000000) indicating the positions of the station.
The next following N lines describe the positions of the agents. Each line consists of two integers X (0 ≤ X ≤ 1000000000) and Y (0 ≤ Y ≤ 1000000000) indicating the positions of the agent.  

 

Output

For each test case output the minimum distance with precision of three decimal placed in a separate line.

 

Sample Input

2
4
0 0
0 1
1 0
1 1
2 2
2 3
3 2
3 3
4
0 0
0 0
0 0
0 0
0 0
0 0
0 0
0 0

 

Sample Output

1.414
0.000

題目大意:給出n個核電站的位置和n個特工的位置,輸出其中特工和核電站最短的距離

解題思路:平面分治最小點對的模板題,不同的是需要將核電站和特工的座標標記分開,

平面分治最小點對: https://blog.csdn.net/qq_40707370/article/details/85268256

AC程式碼:

#include<iostream> 
#include<cmath>
#include<algorithm>
using namespace std;
const int maxn=1e6;
const double INF=1e100; 
struct node{
	double x,y;
	int flag;
}a[maxn],term[maxn];
bool cmpx(node a,node b)
{
	return a.x<b.x;
}
bool cmpy(node a,node b)
{
	return a.y<b.y;
}
double dist(node a,node b)
{
	return sqrt((a.x-b.x)*(a.x-b.x)+(a.y-b.y)*(a.y-b.y));
}
double mindist(int left,int right)
{
	if(left==right)
		return INF;
	if(left+1==right)
	{
		if(a[left].flag==a[right].flag)
			return INF;
		else
			return dist(a[left],a[right]);
	}
	int mid=(left+right)/2;
	double d1=mindist(left,mid);//左區間最小值 
	double d2=mindist(mid+1,right);//右區間最小值 
	double dis=min(d1,d2);
	int i,j,k=0;
	for(i=left;i<=right;i++)
	{
		if(fabs(a[i].x-a[mid].x)<=dis)
			term[k++]=a[i];
	}
	sort(term,term+k,cmpy);
	for(i=0;i<k;i++)
	{
		for(j=i+1;j<k;j++)
		{
			if(term[j].y-term[i].y>dis)
				break;
			if(term[i].flag!=term[j].flag)
				dis=min(dis,dist(term[i],term[j]));
		}
	} 
	return dis;
}
int main()
{
	int t,n;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(int i=0;i<n;i++)
		{
			scanf("%lf%lf",&a[i].x,&a[i].y);
			a[i].flag=0;
		}	
		for(int i=0;i<n;i++)
		{
			scanf("%lf%lf",&a[n+i].x,&a[n+i].y);
			a[n+i].flag=1;
		}
		n*=2; 
		sort(a,a+n,cmpx);
		double ans=mindist(0,n-1);
		printf("%.3lf\n",ans);
	}
	return 0;
}