1086 Tree Traversals Again (25 分)【前序中序轉為後序】
An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
Figure 1
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.
Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
6 Push 1 Push 2 Push 3 Pop Pop Push 4 Pop Pop Push 5 Push 6 Pop Pop
Sample Output:
3 4 2 6 5 1
題意:就是根據pop實現的是中序遍歷,按照壓入的棧中的順序是先序遍歷,最後按照後序遍歷打印出來
解題思路:利用之前的先序中序轉為後序的模板,然後在主函式中將資料稍做處理就行。pop的是中序遍歷,push是先序遍歷,因為題目沒有說明下標不重複,所以需要用value陣列儲存輸入的值(不這樣考慮只有9分),根據字串的長度可以判斷是push還是pop,具體的見程式碼
#include<iostream>
#include<cstdio>
#include<vector>
#include<stack>
#include<cstring>
using namespace std;
vector<int>in,pre,post,value;
int n;
//套模板
void postTravel(int root,int start,int end)
{
if(start>end)
return ;
int i=start;
while(i<end&&in[i]!=pre[root]) i++;
postTravel(root+1,start,i-1);
postTravel(root+1+i-start,i+1,end);
post.push_back(value[pre[root]]);
}
int main(void)
{
scanf("%d",&n);
stack<int>s;
char input[7];
int index=0,a;
for(int i=1;i<=2*n;i++)
{
scanf("%s",input);
if(strlen(input)==4)
{
scanf("%d",&a);
value.push_back(a);
pre.push_back(index);
s.push(index++);
}else{
in.push_back(s.top());
s.pop();
}
}
postTravel(0,0,n-1);
for(int i=0;i<n;i++)
printf("%d%s",post[i],i==n-1?"\n":" ");
return 0;
}