1. 程式人生 > >POJ1163 The Triangle【DP】

POJ1163 The Triangle【DP】

The Triangle
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 58810 Accepted: 35304

Description

7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

Input

Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.

Output

Your program is to write to standard output. The highest sum is written as an integer.

Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Source

IOI 1994

問題連結POJ1163 The Triangle
問題簡述:(略)
問題分析
    動態規劃問題,關鍵是找到狀態轉換方程。不過這個問題的計算過程更為容易想到。
程式說明:(略)
參考連結:(略)
題記

:(略)

AC的C語言程式如下:

/* POJ1163 The Triangle */

#include <iostream>
#include <stdio.h>

using namespace std;

const int N = 100;
int n, dp[N][N];

int solve()
{
    for(int i = n - 2; i >= 0; i--)
        for(int j = 0; j <= i; j++) {
            dp[i][j] += max(dp[i + 1][j], dp[i + 1][j + 1]);
        }
    return dp[0][0];
}

int main()
{
    while(scanf("%d", &n) != EOF) {
        for(int i = 0; i < n; i++)
            for(int j = 0; j <= i; j++)
                scanf("%d", &dp[i][j]);

        printf("%d\n", solve());
    }

    return 0;
}