1. 程式人生 > >寒假訓練01C:hdu1069

寒假訓練01C:hdu1069

Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn’t be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format “Case case: maximum height = height”.

Sample Input
1
10 20 30
2
6 8 10
5 5 5
7
1 1 1
2 2 2
3 3 3
4 4 4
5 5 5
6 6 6
7 7 7
5
31 41 59
26 53 58
97 93 23
84 62 64
33 83 27
0

Sample Output
Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

題目大意
給你n種類型的長方塊,求這些長方塊最高能摞多高(每種長方塊的數量無限制),要求在上面的長方塊長與寬必須嚴格小於下方的長方塊。

解題思路
這道題是一個dp問題,變形的求最大遞減子序列和。因為給的資料並未確定哪個做高,又因為長方塊是無限供應的,所以我們可以把不同的資料做高的三種情況都存進去。又因為在上面的長方塊的面積不可能大於在下面的,所以可以根據面積按從大到小的順序排序,以保證以第i個長方塊為最後一個元素的子序列的前面元素只能在0–i-1中找。最後對處理後的輸出dp後求出的最大值即為所求。

程式碼

#include<iostream>
#include<memory.h>
#include<algorithm>
using namespace std;
class block
{
    public:
    int l;
    int w;
    int h;
    int area;
};
bool cmp(const block &a,const block &b)
{
    return a.area>b.area;
}
int dp[100];
int main()
{
    int n;

    block temp;
    int i,j;
    int x,y,z;
    int cnt=1;
    while(cin>>n&&n!=0)
    {
        memset(dp,0,sizeof(dp));
            block a[100];
            i=1;
            for(j=0;j<n;j++)
            {
                cin>>x>>y>>z;
                 temp.l=x;
                  temp.w=y;
                     temp.area=x*y;
                   temp.h=z;
                  a[i++]=temp;

                 temp.l=z;
                     temp.w=y;
                        temp.area=z*y;
                      temp.h=x;
                   a[i++]=temp;

                 temp.l=x;
                     temp.w=z;
                  temp.area=x*z;
                  temp.h=y;
                    a[i++]=temp;
            }
            sort(a+1,a+3*n+1,cmp);

            for(i=1;i<=3*n;i++)
            {
                dp[i]=a[i].h;
            for(j=1;j<i;j++)
            {
                if(a[i].l<a[j].l&&a[i].w<a[j].w||a[i].l<a[j].w&&a[i].w<a[j].l)
                dp[i]=max(dp[i],dp[j]+a[i].h);

            }
            }
            sort(dp+1,dp+1+3*n);
            cout<<"Case "<<cnt++<<": maximum height = "<<dp[3*n]<<endl;


    }
    return 0;
}