(hdu 2588 gcd)
阿新 • • 發佈:2019-01-22
題目
Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.
Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.
Output
For each test case,output the answer on a single line.
Sample Input
3
1 1
10 2
10000 72
Sample Output
1
6
260
題目的大致意思是:給定n和m,求在所有小於n的正整數中,有幾個和n的gcd大於等於m。多組資料
題解
- 如果gcd(a,b)=c 那麼gcd(a/c,b/c)=1
- 此時求的是對於一個數x,首先它要大於m,那麼只需要gcd(n,x*q)=x,q是正整數且x*q<=n
- gcd(n,x*q)=x等價於gcd(n/x,q)=1
- 因此只需要用尤拉函式算出與n/x互質的數有多少即可,同時可以避免重複
程式碼
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int T;
int n,m;
int ans;
int euler(int x){//計算某個數的尤拉函式值
int tmp=1,i;
for(i=2;i*i<=x;i++)
{
if(x%i==0)
{
x/=i;tmp*=i-1;
while(x%i==0)
{x/=i;tmp*=i;}
}
}
if(x>1)
tmp*=x-1;
return tmp;
}
int main(){
scanf("%d",&T);
while(T--){
ans=0;
scanf("%d%d",&n,&m);
for(int i=1;i*i<=n;++i){
if(n%i==0){
if(i>=m) ans+=euler(n/i);
if(i*i!=n&&n/i>=m) ans+=euler(i);//兩步一起寫可以少迴圈。i*i!=n 用於判重
}
}
printf("%d\n",ans);
}
return 0;
}