1. 程式人生 > >poj 2421(最小生成樹)

poj 2421(最小生成樹)

Constructing Roads
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 15536 Accepted: 6291

Description

There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected. 

We know that there are already some roads between some villages and your job is the build some roads such that all the villages are connect and the length of all the roads built is minimum.

Input

The first line is an integer N (3 <= N <= 100), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 1000]) between village i and village j. 

Then there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each line contains two integers a and b (1 <= a < b <= N), which means the road between village a and village b has been built.

Output

You should output a line contains an integer, which is the length of all the roads to be built such that all the villages are connected, and this value is minimum.

Sample Input

3
0 990 692
990 0 179
692 179 0
1
1 2

Sample Output

179

Source

題目型別:最小生成樹 題目描述:建路使得N個村莊互相連通,要求最小的權值。而且,有一些路已經建好了。 題目分析:路已經建好了,相當於該條邊已經被加到了最小生成樹中。對應的操作就應該是合併村莊,加上此邊的權值。 因為是事先建好的路,所以不用加權值。處理完之後再Kruskal就行了。 程式碼如下:
#include <iostream>
#include <stdio.h>
#include <algorithm>
#define V 101
#define E V * (V-1) / 2
using namespace std;

struct Edge{
    int u;
    int v;
    int w;
};
Edge edge[E];
int rank[V];
int f[V];
int n;

bool cmp(Edge a,Edge b){
    if( a.w < b.w ){
        return true;
    } else {
        return false;
    }
}

void makeSet(){
    for(int i = 1; i <= n; i++){
        f[i] = i;
        rank[i] = 0;
    }
}
int findRoot(int x){
    if( x == f[x]) {
        return x;
    } else {
        return f[x] = findRoot(f[x]);
    }
}
void merge(int a,int b){
    int ra = findRoot(a);
    int rb = findRoot(b);
    if(ra != rb){
        if(rank[ra] < rank[rb]){
            f[ra] = rb;
        } else {
            f[rb] = ra;
            if(rank[ra] == rank[rb]) {
                rank[ra]++;
            }
        }
    }
}


int main()
{
    while(scanf("%d",&n) != EOF){
        int result = 0;
        int k = -1;
        for(int i = 1; i <= n; i++){
            for(int j = 1; j <= n; j++) {
                int w;
                scanf("%d",&w);
                if( j > i) {
                    k++;
                    edge[k].u = i;
                    edge[k].v = j;
                    edge[k].w = w;
                }
            }
        }
        makeSet();
        int q,a,b;
        scanf("%d",&q);
        while(q--){
            scanf("%d%d",&a,&b);
            merge(a,b);
        }
        sort(edge,edge+k+1,cmp);
        for(int i = 0; i <= k; i++){
            int ru = findRoot(edge[i].u);
            int rv = findRoot(edge[i].v);
            if(ru != rv) {
                result += edge[i].w;
                merge(edge[i].u,edge[i].v);
            }
        }
        printf("%d\n",result);

    }

    return 0;
}