1. 程式人生 > >POJ 2586 Y2K Accounting Bug (貪心)

POJ 2586 Y2K Accounting Bug (貪心)

Y2K Accounting Bug
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 13878 Accepted: 7019

Description

Accounting for Computer Machinists (ACM) has sufferred from the Y2K bug and lost some vital data for preparing annual report for MS Inc. 
All what they remember is that MS Inc. posted a surplus or a deficit each month of 1999 and each month when MS Inc. posted surplus, the amount of surplus was s and each month when MS Inc. posted deficit, the deficit was d. They do not remember which or how many months posted surplus or deficit. MS Inc., unlike other companies, posts their earnings for each consecutive 5 months during a year. ACM knows that each of these 8 postings reported a deficit but they do not know how much. The chief accountant is almost sure that MS Inc. was about to post surplus for the entire year of 1999. Almost but not quite. 

Write a program, which decides whether MS Inc. suffered a deficit during 1999, or if a surplus for 1999 was possible, what is the maximum amount of surplus that they can post.

Input

Input is a sequence of lines, each containing two positive integers s and d.

Output

For each line of input, output one line containing either a single integer giving the amount of surplus for the entire year, or output Deficit if it is impossible.

Sample Input

59 237
375 743
200000 849694
2500000 8000000

Sample Output

116
28
300612
Deficit

Source

題意:一個公司不記得一年中哪個月盈利哪個月虧損,但是知道某連續5個月之和是虧損的,輸入每月固定盈利S和固定虧損D後,問一年可能盈利嗎,如果可能輸出最大盈利額,不可能則輸出“Deficit”。

思路:因為連續5個月之和總是虧損,所以儘量把D放在連續5個月的後面,計算多次虧損。

所以有5種情況:

SSSSDSSSSDSS  ,該情況下D>4S

SSSDDSSSDDSS  ,2D>3S

SSDDDSSDDDSS   ,3D>2S

SDDDDSDDDDSD  ,4D>S

DDDDDDDDDDDD  ,不可能盈利。

所以我們對S進行討論。

#include <cstdio>  
#include <cstring>  
#include <cmath>  
#include <cstdlib>  
#include <algorithm>  
#include <queue>  
#include <stack>  
#include <map>  
#include <vector>  
#include <iostream>
#define INF 0x3f3f3f3f  
#define eps 1e-4  
#define MAXN (1000+10)  
#define MAXM (1000000)  
#define CLR(a, b) memset(a, (b), sizeof(a))  
#define MOD 100000007  
#define LL long long  
#define lson node<<1, l, mid  
#define rson node<<1|1, mid+1, r   
using namespace std;

int main() {
	int s, d,surplus=0;
	while (cin >> s >> d) {
		bool flag = false;
		if (s > 4 * d) flag = true;
		else if (s < 4 * d && s >= 1.5*d) {
			surplus = 3 * s - 9 * d;
			if (surplus < 0)
				flag = true;
		}
		else if (s < 1.5*d && s >= 0.666666*d) {
			surplus = 6 * s - 6 * d;
			if (surplus < 0)
				flag = true;
		}
		else if (s < 0.666666*d && s >= 0.25*d) {
			surplus = 8 * s - 4 * d;
			if (surplus < 0)
				flag = true;
		}
		else if (s < 0.25*d && s >= 0) {
			surplus = 10 * s - 2 * d;
			if (surplus < 0)
				flag = true;
		}
		if (flag) {
			cout << "Deficit" << endl;
		}
		else {
			cout << surplus << endl;
		}
	}
	return 0;
}