1. 程式人生 > >HDU 4496 D-City 並查集倒排加邊

HDU 4496 D-City 並查集倒排加邊

D-City

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 4344 Accepted Submission(s): 1530

Problem Description
Luxer is a really bad guy. He destroys everything he met.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input.
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.

Input
First line of the input contains two integers N and M.
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.
Constraints:
0 < N <= 10000
0 < M <= 100000
0 <= u, v < N.

Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.

Sample Input
5 10
0 1
1 2
1 3
1 4
0 2
2 3
0 4
0 3
3 4
2 4

Sample Output
1
1
1
2
2
2
2
3
4
5
Hint

The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there’s only 1 connected block at first.
The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together.
But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block.
Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.

題意

給出點的個數和邊,輸出去掉前k條邊的時候非連通集合有多少個?

題解

這題是很明顯的並查集,很重要的一點是去掉前k條邊,完全可以倒過來求解,也就是從最後一條邊開始慢慢加邊。
在計算的時候,開始非連通集合就是點的個數n,之後每一個點併入任一連通集合,非連通集合的個數就-1.
不用倒排加邊,基本上是TLE......
#include <bits/stdc++.h>
//#include<stdio.h>
//#include<stdlib.h>
//#include<math.h>
//#include<algorithm>
//#include<string.h>
//#include<string>
//#include<stack>
//#include<queue>
//#define INF 0xffffffff
using namespace std;
typedef long long ll;

const int maxn = 10005;
const int maxm = 100005;

int tol;

struct Edge{
    int u, v;
}edge[maxm];

int n, m;
int f[maxn];
int ans[maxm];

void addedge(int u, int v){
    edge[tol].u = u;
    edge[tol++].v = v;
}

int find(int x){
    return (x == f[x])? f[x] : f[x]=find(f[x]);
}

int main(){
    while(scanf("%d%d", &n, &m) == 2 && n && m){
        tol = 0;
        for(int i=0; i<n; i++){
            f[i] = i;
        }
        for(int i=0; i<m; i++){
            int u, v;
            scanf("%d%d", &u, &v);
            addedge(u, v);
        }
        int cnt = n;
        for(int i=m-1; i>=0; i--){
            ans[i] = cnt;
            int u = edge[i].u;
            int v = edge[i].v;
            int t1 = find(u);
            int t2 = find(v);
            if(t1 != t2){
                f[t1] = t2;
                cnt -- ;
            }
        }
        for(int i=0; i<m; i++){
            printf("%d\n", ans[i]);
        }
    }
    return 0;
}