1. 程式人生 > >HDU 4496 D-City (並查集的應用)逆向思維

HDU 4496 D-City (並查集的應用)逆向思維

D-City

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 1237    Accepted Submission(s): 467


Problem Description Luxer is a really bad guy. He destroys everything he met.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input.
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.
Input First line of the input contains two integers N and M.
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.
Constraints:
0 < N <= 10000
0 < M <= 100000
0 <= u, v < N.

Output Output M lines, the ith line is the answer after deleting the first i edges in the input.
Sample Input 5 10 0 1 1 2 1 3 1 4 0 2 2 3 0 4 0 3 3 4 2 4
Sample Output 1 1 1 2 2 2 2 3 4 5 Hint
The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there's only 1 connected block at first. The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together. But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block. Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.

題意:題目給出一個聯通圖,現在要逐個刪除點之間的邊,求每次刪除後的聯通塊個數

思路:可以逆向思維,最後肯定是孤立的點然後依次將點連起來

AC程式碼:
#include <stdio.h>
//author:YangSir
#define max 100005
int u[max],v[max],ans[max];
int f[10005];
int find(int x){return x==f[x]?x:f[x]=find(f[x]);}
int main(){
	int n,m,i,a,b;
	while(~scanf("%d%d",&n,&m)){
		for(i=0;i<n;i++)
			f[i]=i;
		for(i=0;i<m;i++)
			scanf("%d%d",&u[i],&v[i]);
		for(i=m-1;i>=0;i--){//從後面出發
			ans[i]=n;
			a=find(u[i]);
			b=find(v[i]);
			if(a!=b){
				f[a]=b;//建立父子關係,關聯起來
				n--;//聯通塊少一塊
			}
		}
		for(i=0;i<m;i++)
			printf("%d\n",ans[i]);
	}
	return 0;
}