1. 程式人生 > >人見人愛A^B(快速冪)

人見人愛A^B(快速冪)

人見人愛A^B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 42339    Accepted Submission(s): 28587


Problem Description 求A^B的最後三位數表示的整數。
說明:A^B的含義是“A的B次方”

Input 輸入資料包含多個測試例項,每個例項佔一行,由兩個正整數A和B組成(1<=A,B<=10000),如果A=0, B=0,則表示輸入資料的結束,不做處理。
Output 對於每個測試例項,請輸出A^B的最後三位表示的整數,每個輸出佔一行。

Sample Input 2 3 12 6 6789 10000 0 0
Sample Output 8 984 1
#include <cstdio>  
#include <cstring>  
#include <queue>  
#include <cmath>  
#include <stack>  
#include <vector>  
#include <algorithm>
#include <map>  
using namespace std;  

#define INF 0x3f3f3f3f  
#define CLR(a,b) memset(a,b,sizeof(a))  
#define PI acos(-1.0)  
#define LL long long

int main(void){
//freopen("題.txt", "r", stdin);
int n, m, an;
while(scanf("%d%d", &n, &m) != EOF,n && m){
	int temp = 1;
	for(int i = 0; i < m; i++){
		temp = (n%1000) * (temp%1000) % 1000;
	}
	printf("%d\n", temp);
}
	return 0;
}