1. 程式人生 > >HDU-大數取模-最多100000位

HDU-大數取模-最多100000位

問題及程式碼:

/* 
*Copyright (c)2014,煙臺大學計算機與控制工程學院 
*All rights reserved. 
*檔名稱:mod.cpp 
*作    者:單昕昕 
*完成日期:2015年2月3日 
*版 本 號:v1.0 
* 
*問題描述:As we know, Big Number is always troublesome. But it's really important in our ACM. And today, your task is to write a program to calculate A mod B.

To make the problem easier, I promise that B will be smaller than 100000.

Is it too hard? No, I work it out in 10 minutes, and my program contains less than 25 lines.
*程式輸入:The input contains several test cases. Each test case consists of two positive integers A and B. The length of A will not exceed 1000, and B will be smaller than 100000. Process to the end of file.
*程式輸出:For each test case, you have to ouput the result of A mod B.
Sample Input
2 3
12 7
152455856554521 3250
Sample Output
2
5
1521
*/
#include<iostream>
#include<cstring>
using namespace std;
int main()
{
	char str[100000];
	int s,len,sum,i;
	while(cin>>str>>s)
	{
		len=strlen(str);
		sum=0;
		for(i=0;i<len;i++)
		sum=(sum*10+(str[i]-'0')%s)%s;
		cout<<sum<<endl;
	}
	return 0;
}


執行結果:

知識點總結:

大數取模。

我一開始想會不會有下面這些的結論,後來一百度發現還真有。

對於大數問題,從來都只能巧勝~~~

A*B % C = (A%C * B%C)%C
(A+B)%C = (A%C + B%C)%C
如 532 mod 7 =(500%7+30%7+2%7)%7;
當然還有a*b mod c=(a mod c+b mod c)mod c;
如35 mod 3=((5%3)*(7%3))%3

學習心得:

大數問題真是硬傷,上週的題目被虐的死去活來的。。