遞推:Number Sequence(mod找規律)
解題心得:
1、對於資料很大,很可怕,不可能用常規手段算出最後的值在進行mod的時候,可以思考找規律。
2、找規律時不必用手算(我傻,用手算了好久)。直接先找前100項進行mod打一個表出來,直接看就行了。
3、對於像斐波那契數列(本題)的那樣,憑藉肉眼無法找到規律的時候,可以觀察本題的特點。那就是,第一項和第二項不會變,都為1,1。所以迴圈的時候必定是以1、1為開始,中間的數可以直接記錄,很玄幻。
4、還是邊界問題,這很重要,這時候數列儘量從1開始,因為在詢問的時候都是詢問的第n個數,要時刻保持清醒不然要弄得自己很混亂,比如n 個迴圈一次那麼,m%n == 0的時候剛好是最後一個,m%n == 1的時候才是第一個。
題目:
Problem Description
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
Output
For each test case, print the value of f(n) on a single line.
Sample Input
1 1 3
1 2 10
0 0 0
Sample Output
2
5
#include<stdio.h>
int main()
{
int num[100];
int a,b,n,i;
num[0]= 1;//從一開始其實更簡單
num[1]= 1;
while(scanf("%d%d%d",&a,&b,&n)!=EOF)
{
if (a == 0 && b == 0 && n == 0)
break;
for(i=2;i<50;i++)
/*由於f(n)是由前兩個數字組合產生,那麼只要有兩個數字組合相同的情況發生就一定一會產生迴圈!
兩個數字的組合的最大可能值為7x7=49,因此只要在呼叫迭代方法中限制n的在0~48就可以了*/ {
num[i] = (a*num[i-1] + b*num[i-2])%7;
if(num[i] == 1 && num[i-1] == 1)
break;
}
n = n%(i-1);
if(n == 0)//這裡需要討論,注意是i-2,第i-1項,數列中第i-2個
printf("%d\n",num[i-2]);
else
printf("%d\n",num[n-1]);
}
}