1. 程式人生 > >Number Sequence(找規律)

Number Sequence(找規律)

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 151858    Accepted Submission(s): 36937


Problem Description A number sequence is defined as follows:

f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.

Given A, B, and n, you are to calculate the value of f(n).

Input The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.

Output For each test case, print the value of f(n) on a single line.

Sample Input 1 1 3 1 2 10 0 0 0
Sample Output 2 5
Author CHEN, Shunbao
Source

往後找規律就行了,為了避免前兩項為1後面都為0的情況的干擾,從第三第四項開始找週期。

程式碼如下:

#include <cstdio>
int main()
{
	int a,b,n;
	int f[10001];
	f[1] = 1;
	f[2] = 1;
	int s;		//記錄週期 
	while (~scanf ("%d %d %d",&a,&b,&n) && (a || b || n))
	{
		if (n == 1 || n == 2)
		{
			printf ("1\n");
			continue;
		}
		a %= 7;
		b %= 7;
		f[3] = (a * f[2] + b * f[1]) % 7;		//先求兩項(為了避免後面都為0的情況) 
		f[4] = (a * f[3] + b * f[2]) % 7;
		for (int i = 5 ; ; i++)
		{
			f[i] = (a * f[i-1] + b * f[i-2]) % 7;
			if (f[i] == f[4] && f[i-1] == f[3]) 		//兩項相等就開始迴圈
			{
				s = i - 4;
				break;
			}
		}
//		int pos = (n - 2) % s;
//		pos = pos == 0 ? s : pos;		//餘數為0取最後一項
		int pos = (n - 3) % s + 1;		//這樣的寫法比上面的巧,小細節,學習一下 
		printf ("%d\n",f[2+pos]);
	}
	return 0;
}