1. 程式人生 > >2386 Lake Counting(簡單深搜)

2386 Lake Counting(簡單深搜)

Lake Counting
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 38395 Accepted: 19066

Description

Due to recent rains, water has pooled in various places in Farmer John's field, which is represented by a rectangle of N x M (1 <= N <= 100; 1 <= M <= 100) squares. Each square contains either water ('W') or dry land ('.'). Farmer John would like to figure out how many ponds have formed in his field. A pond is a connected set of squares with water in them, where a square is considered adjacent to all eight of its neighbors. 

Given a diagram of Farmer John's field, determine how many ponds he has.

Input

* Line 1: Two space-separated integers: N and M 

* Lines 2..N+1: M characters per line representing one row of Farmer John's field. Each character is either 'W' or '.'. The characters do not have spaces between them.

Output

* Line 1: The number of ponds in Farmer John's field.

Sample Input

10 12
W........WW.
.WWW.....WWW
....WW...WW.
.........WW.
.........W..
..W......W..
.W.W.....WW.
W.W.W.....W.
.W.W......W.
..W.......W.

Sample Output

3
題意:計算出湖的數目;

思路:題目中指出是八個方向的搜尋,用深搜列舉八個方向計算出湖的數目。

#include<stdio.h>

char Map[110][110];//建圖和標記兩個功能
int dir[8][2] = {0,1,1,1,1,0,1,-1,0,-1,-1,-1,-1,0,-1,1};//八個方向
int r,c;

void dfs(int x,int y)
{
    int i;
    for(i = 0; i < 8; i ++)//列舉八個方向
    {
        int tx = x + dir[i][0];
        int ty = y + dir[i][1];
        if(tx<r && tx>=0 && ty<c && ty>=0 && Map[tx][ty]=='W')
        {
            Map[tx][ty] = '.';//標記已搜過
            dfs(tx,ty);
        }
    }
}

int main()
{
    int i,j,k;
    while(~scanf("%d%d",&r,&c))
    {
        for(i = 0; i < r; i ++)
            scanf("%s",Map[i]);
        int sum = 0;
        for(i = 0; i < r; i ++)
        {
            for(j = 0; j < c; j ++)
            {
                if(Map[i][j]=='W')//一趟搜尋得到一個湖
                {
                    dfs(i,j);
                    sum++;
                }
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}