1. 程式人生 > >LightOJ 1214(大數相除)

LightOJ 1214(大數相除)

                                                                                           Large Division

Description

Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.

Input

Input starts with an integer T (≤ 525), denoting the number of test cases.

Each case starts with a line containing two integers a (-10200

 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case, print the case number first. Then print 'divisible' if a is divisible by b. Otherwise print 'not divisible'.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible

直接上Java

import java.io.*;
import java.util.*;
import java.math.*;

public class Main {

	public static void main(String[] args) {
		// TODO Auto-generated method stub
		Scanner in = new Scanner(System.in);
		BigInteger a, b;
		int t;
		t = in.nextInt();
		for (int i = 1; i <= t; i++) {
			a = in.nextBigInteger();
			b = in.nextBigInteger();
			if(b.compareTo(BigInteger.ZERO)<0) b=b.multiply(BigInteger.valueOf(-1));
			BigInteger c = a.mod(b);
			if (c == BigInteger.ZERO)
				System.out.println("Case " + i + ": " + "divisible");
			else
				System.out.println("Case " + i + ": " + "not divisible");
		}
	}

}