1. 程式人生 > >hdu1394 Minimum Inversion Number

hdu1394 Minimum Inversion Number

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3796    Accepted Submission(s): 2309


 

Problem Description

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)
You are asked to write a program to find the minimum inversion number out of the above sequences.

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

Output

For each case, output the minimum inversion number on a single line.

Sample Input
10 1 3 6 9 0 8 5 7 4 2

Sample Output

16

動動腦子,題目說是一個環

那麼每轉一次,就相當於把第一個數放到最後面

考慮第一個數對原有答案的貢獻是a[1]-1,也就是小於它的個數(資料是1到n的排列)

最後一個數對原答案的貢獻相反

那麼移動後當前逆序對數就要減去比第一個數小的個數,再加上比它大的數的個數

這樣我們求出一次移動後的逆序對數

這時候我們發現下一次移動直接修改答案就好,不需要改動樹狀陣列

推出式子ans+=n-a[i]-(a[i]-1)

code:

#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#define LL long long
int bit[5050]={0},n,a[5050];
inline LL min(LL a,LL b){
    return a<b?a:b;
}
inline int lb(int x){
    return x&(-x);
}
inline LL q(int x){
    LL ans=0;
    while(x){
        ans+=bit[x];
        x-=lb(x);
    }
    return ans;
}
inline int c(int x){
    while(x<=n){
        bit[x]++;
        x+=lb(x);
    }
    return 0;
}
int main(){
    while(scanf("%d",&n)!=EOF){
        memset(bit,0,sizeof(bit));
        LL ans=0;
        for(int i=1;i<=n;i++){
            scanf("%d",&a[i]);
            a[i]++;
            ans+=q(n)-q(a[i]);
            c(a[i]);
        }
        LL mn=ans;
        mn=min(mn,ans);
        for(int i=1;i<=n;i++){
            ans+=n-a[i]-(a[i]-1);
            mn=min(mn,ans);
        }
        printf("%lld\n",mn);
    }
    
    return 0;
}