1. 程式人生 > >PAT1054 The Dominant Color

PAT1054 The Dominant Color

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800x600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (<=800) and N (<=600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0, 2^24^). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24

注意:輸入的資料定義為string型別時會導致第3個測試點超時,應直接定義為字元陣列型別。

#include <iostream>
#include <string>
#include <map>
using namespace std;
map<string,int> mp;
int main()
{
//	freopen("10.txt","r",stdin);
	int M, N;
	scanf("%d%d", &M, &N);
	char kk[15];
    for(int i = 0; i < N; i++){
    	for(int j = 0; j < M; j++){
    		    scanf("%s",kk);
    			mp[kk]++;
			}
		}
	
	int half = M*N/2 + 1;
	map<string,int>::iterator it; 
	for(it = mp.begin(); it != mp.end(); it++){
		 if(it->second >= half) break;
	}
    cout<< it->first <<endl;	
}

還有就是,迭代器it要在for迴圈之前定義,不然會導致輸出結果時出錯。