1. 程式人生 > >Elven Postman【二叉樹還原】

Elven Postman【二叉樹還原】

Elven Postman

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 2652    Accepted Submission(s): 1587


 

Problem Description

Elves are very peculiar creatures. As we all know, they can live for a very long time and their magical prowess are not something to be taken lightly. Also, they live on trees. However, there is something about them you may not know. Although delivering stuffs through magical teleportation is extremely convenient (much like emails). They still sometimes prefer other more “traditional” methods.

So, as a elven postman, it is crucial to understand how to deliver the mail to the correct room of the tree. The elven tree always branches into no more than two paths upon intersection, either in the east direction or the west. It coincidentally looks awfully like a binary tree we human computer scientist know. Not only that, when numbering the rooms, they always number the room number from the east-most position to the west. For rooms in the east are usually more preferable and more expensive due to they having the privilege to see the sunrise, which matters a lot in elven culture.

Anyways, the elves usually wrote down all the rooms in a sequence at the root of the tree so that the postman may know how to deliver the mail. The sequence is written as follows, it will go straight to visit the east-most room and write down every room it encountered along the way. After the first room is reached, it will then go to the next unvisited east-most room, writing down every unvisited room on the way as well until all rooms are visited.

Your task is to determine how to reach a certain room given the sequence written on the root.

For instance, the sequence 2, 1, 4, 3 would be written on the root of the following tree.

Input

First you are given an integer T(T≤10) indicating the number of test cases.

For each test case, there is a number n(n≤1000) on a line representing the number of rooms in this tree. n integers representing the sequence written at the root follow, respectively a1,...,an where a1,...,an∈{1,...,n

}.

On the next line, there is a number q representing the number of mails to be sent. After that, there will be q integers x1,...,xq indicating the destination room number of each mail.

Output

For each query, output a sequence of move (E or W) the postman needs to make to deliver the mail. For that E

means that the postman should move up the eastern branch and W the western one. If the destination is on the root, just output a blank line would suffice.

Note that for simplicity, we assume the postman always starts from the root regardless of the room he had just visited.

Sample Input

2 4 2 1 4 3 3 1 2 3 6 6 5 4 3 2 1 1 1

Sample Output

E WE EEEEE

Source

按照題意,1到n為此樹的中序遍歷結果。然後給出的序列為二叉樹的前序遍歷結果。我的做法是還原二叉樹,因為每一個點只有一個父親節點,所以我把還原的結果用其父親節點和本節點屬於父親節點的左子樹還是右子樹表示。在詢問某一個點時,沿著這條路徑找到根節點即可。

#include<iostream>
using namespace std;
const int maxn=1005;
class Node{
	public:
		int gen;//根節點 
		bool left;//左為true 
}; 
Node ans[maxn];
int a[maxn];
int n;

void jiexi(int l,int r,int gen,bool left){
	if(r<l)return;
	
	int p=a[l];
	ans[p].gen=gen;
	ans[p].left=left;
	int k=l+1;
	for(;k<=r;k++){
		if(a[k]>p)break;
	}
	if(k>r){//只有左子樹 
		jiexi(l+1,r,p,true); 
	}else if(k==l+1){
		jiexi(l+1,r,p,false); 
	}else{
		jiexi(l+1,k-1,p,true); 
		jiexi(k,r,p,false); 
	}
} 

int main(){
	int T;cin>>T;
	while(T--){
		cin>>n;
		for(int i=1;i<=n;i++){
			cin>>a[i];
		}
		//解析 
		jiexi(1,n,0,true);
//		for(int i=1;i<=n;i++){
//			cout<<i<<" "<<ans[i].gen<<" "<<ans[i].left<<endl;
//		}
//		system("pause");
		int q;cin>>q;int t;
		while(q--){
			cin>>t;
			string str;
			while(ans[t].gen!=0){
				if(ans[t].left)str+="E";
				else str+="W";
				t=ans[t].gen;
			}
			for(int i=str.length()-1;i>=0;i--)cout<<str[i];
			cout<<endl;
			
		}
		
		
	}
	
	return 0;
}