1. 程式人生 > >【PAT】1037. Magic Coupon (25)

【PAT】1037. Magic Coupon (25)

題目描述

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product… but hey, magically, they have some coupons with negative N’s!

For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M $7) to get M$28 back; coupon 2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$

3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

翻譯:火星上的魔法商店提供了一些不可思議的優惠券。每張優惠券上面有一個正整數N,這意味著當你對一個商品使用此優惠券,你可能獲得N倍這個商品的價值!還有,這個商店也提供一些免費的商品。但是,如果你用一個正整數N的優惠券去買這個商品,你需要給商店N倍這個商品的價值。。。但是,神奇的是,他們有些優惠券是負整數N!

INPUT FORMAT

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC, NP <= 105, and it is guaranteed that all the numbers will not exceed 230.

翻譯:每個輸入檔案包含一組測試資料。對於每組輸入資料,第一行包括優惠券數NC,跟著一行包括N個正整數代表每張優惠券的值。接著一行為商品數NP,接著為NP個數代表每個商品的價值。1<= NC, NP <= 10^5,資料保證所有數字都不會超過2^30。

OUTPUT FORMAT

For each test case, simply print in a line the maximum amount of money you can get back.

翻譯:對於每組輸入資料,輸出一行你可以獲得的金錢的最大值。

Sample Input:

4
1 2 4 -1
4
7 6 -2 -3

Sample Output:

43

解題思路

這道題難點是在讀題吧。。。其實就是排序後從兩邊取數相乘,遇到符號不同就停止。我選擇用優先佇列分別儲存兩個數列中的正數和負數,將它們相乘後相加即為答案。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<queue>
#include<algorithm>
#define INF 99999999
using namespace std;
priority_queue<int> pos[2];
priority_queue<int> neg[2];
int N;
int main(){
    for(int i=0;i<2;i++){
        scanf("%d",&N);
        int a;
        for(int j=0;j<N;j++){
            scanf("%d",&a);
            if(a>0)pos[i].push(a);
            if(a<0)neg[i].push(-a);
        }
    }
    int l1=min(pos[0].size(),pos[1].size());
    int l2=min(neg[0].size(),neg[1].size());
    int sum=0;
    for(int i=0;i<l1;i++){
        int t1=pos[0].top();pos[0].pop();
        int t2=pos[1].top();pos[1].pop();
        sum+=t1*t2;
    }
    for(int i=0;i<l2;i++){
        int t1=neg[0].top();neg[0].pop();
        int t2=neg[1].top();neg[1].pop();
        sum+=t1*t2;
    }   
    printf("%d\n",sum);
    return 0;
}