1. 程式人生 > >【PAT】1048.Find Coins (25)

【PAT】1048.Find Coins (25)

題目描述

Eva loves to collect coins from all over the universe, including some other planets like Mars. One day she visited a universal shopping mall which could accept all kinds of coins as payments. However, there was a special requirement of the payment: for each bill, she could only use exactly two coins to pay the exact amount. Since she has as many as 105 coins with her, she definitely needs your help. You are supposed to tell her, for any given amount of money, whether or not she can find two coins to pay for it.

翻譯:Eva喜歡收集來自宇宙各地的硬幣,包括一些其他的星球比如火星。一天她在一個可以支付所有型別的硬幣的購物廣場逛街。但是,每次支付都有一個很奇怪的要求,她只能用兩個硬幣支付且價值要一模一樣。由於她帶了10^5個硬幣,她十分需要你的幫助。你需要告訴她,對於給出的價格,她是否可以找到兩個硬幣去支付。

INPUT FORMAT

Each input file contains one test case. For each case, the first line contains 2 positive numbers: N (<=105, the total number of coins) and M(<=103, the amount of money Eva has to pay). The second line contains N face values of the coins, which are all positive numbers no more than 500. All the numbers in a line are separated by a space.

翻譯:每個輸入檔案包含一組測試資料。對於每組輸入資料,第一行包括2個正整數N(<=10^5)代表硬幣總數,和M(<=10^3),代表Eva需要支付的價格。第二行包括N個硬幣的表面價值,均為不超過500的正整數。一行內所有數字之間都用空格隔開。

OUTPUT FORMAT

For each test case, print in one line the two face values V1 and V2 (separated by a space) such that V1 + V2 = M and V1 <= V2. If such a solution is not unique, output the one with the smallest V1. If there is no solution, output “No Solution” instead.

翻譯:對於每組輸入資料,輸出一行兩個價值V1和V2(用空格隔開),V1 + V2 = M and V1 <= V2。如果答案不唯一,輸出最小的V1。如果沒有結果,輸出”No Solution”。

Sample Input 1:

8 15
1 2 8 7 2 4 11 15

Sample Output 1:

4 11

Sample Input 2:

7 14
1 8 7 2 4 11 15

Sample Output 2:

No Solution

解題思路

由於這道題M<=1000,N<=100000,所以選擇用雜湊記錄數字M出現次數,然後從1—M/2列舉,判斷i和M-i是否出現過。注意如果i==M-i,則i出現次數要大於等於2次。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#define INF 99999999
using namespace std;
int N,M,m[1010];
int main(){
    scanf("%d%d",&N,&M);
    int a;
    for(int i=0;i<N;i++){
        scanf("%d",&a);
        m[a]++;
    }
    int flag=0;
    for(int i=1;i<=M/2;i++){
        int temp=M-i;
        if(temp==i&&m[temp]>=2||(temp!=i&&m[temp]&&m[i])){
            printf("%d %d\n",i,temp);
            flag=1;
            break;      
        }   
    }
    if(!flag)printf("No Solution\n");
    return 0;
}