poj3311 TSP問題 狀態壓縮dp
Hie with the Pie
Description
The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.
Input
Input will consist of multiple test cases. The first line will contain a single integer n indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will be n + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and the n locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to location j without visiting any other locations along the way. Note that there may be quicker ways to go from i to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from location i to j may not be the same as the time to go directly from location j to i. An input value of n = 0 will terminate input.
Output
For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.
Sample Input
3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0
Sample Output
8
分析:
n不大,因此可用 floyd 打表求一下從城市i到城市j需要花費的最小時間。
狀態的編碼方式:從高位到低位依次是:城市0 - > 城市n。0表示沒走過該城市,1
列舉每個狀態,將狀態state 依次與(1<<(k-1))(k=1 - > n) 相與,若結果為1表明走過城市k-1。
#include<iostream>
#include<cstdio>
#include<algorithm>
#define ll long long
using namespace std;
int d[12][12];
ll dp[2100][12]; //dp[i][j]表示i狀態時走到城市j時的最小花費
int n;
int main()
{
while(scanf("%d",&n)==1&&n)
{
for(int i=0;i<=n;i++)
for(int j=0;j<=n;j++)
scanf("%d",&d[i][j]);
for(int k=0;k<=n;k++)
for(int i=0;i<=n;i++)
for(int j=0;j<=n;j++)
d[i][j]=min(d[i][j],d[i][k]+d[k][j]);
int m=(1<<n)-1;
for(int i=0;i<=m;i++)
{
for(int k=1;k<=n;k++)
{
if(i&(1<<(k-1))) //走過城市k
{
if(i==(1<<(k-1)))
dp[i][k]=d[0][k];
else
{
dp[i][k]=1<<30;
for(int t=1;t<=n;t++)
{
if(t!=k&&(i&(1<<(t-1))))
dp[i][k]=min(dp[i][k],dp[i^(1<<(k-1))][t]+d[t][k]);
}
}
}
}
}
ll ans=(1<<31)-1;
for(int i=1;i<=n;i++)
ans=min(ans,dp[(1<<n)-1][i]+d[i][0]);
printf("%lld\n",ans);
}
return 0;
}